<!DOCTYPE html><html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" prefix="og: https://ogp.me/ns#"><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://countercurrents.org/xmlrpc.php" /><link media="all" href="https://cdn.countercurrents.org/wp-content/cache/autoptimize/css/autoptimize_42b74081ae48be8132dba2c9b9d562fa.css" rel="stylesheet" /><link media="screen" href="https://cdn.countercurrents.org/wp-content/cache/autoptimize/css/autoptimize_4d36d0bc18b9218b407ed7bd9e4fd7da.css" rel="stylesheet" /><title>Remembering T.Nagi Reddy, His College Days In BHU And MK Gandhi| Countercurrents</title><meta name="description" content="T.Nagi Reddy died 46 years ago on July28,1976, and DV Rao died on July12, 1984. Every year in  July, meetings, small and big, are held across Telangana and"/><meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/><link rel="canonical" href="https://countercurrents.org/2022/07/remembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Remembering T.Nagi Reddy, His College Days In BHU And MK Gandhi| Countercurrents" /><meta property="og:description" content="T.Nagi Reddy died 46 years ago on July28,1976, and DV Rao died on July12, 1984. Every year in  July, meetings, small and big, are held across Telangana and" /><meta property="og:url" content="https://countercurrents.org/2022/07/remembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi/" /><meta property="og:site_name" content="Countercurrents" /><meta property="article:publisher" content="https://facebook.com/countercurrents" /><meta property="article:tag" content="DV Rao" /><meta property="article:tag" content="T Nagi Reddy" /><meta property="article:section" content="Life/Philosophy" /><meta property="fb:app_id" content="549668832363418" /><meta property="og:image" content="https://cdn.countercurrents.org/wp-content/uploads/2022/07/TN-DV.jpg" /><meta property="og:image:secure_url" content="https://cdn.countercurrents.org/wp-content/uploads/2022/07/TN-DV.jpg" /><meta property="og:image:width" content="700" /><meta property="og:image:height" content="452" /><meta property="og:image:alt" content="Nagi Reddy" /><meta property="og:image:type" content="image/jpeg" /><meta property="article:published_time" content="2022-07-28T11:20:49+05:30" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:title" content="Remembering T.Nagi Reddy, His College Days In BHU And MK Gandhi| Countercurrents" /><meta name="twitter:description" content="T.Nagi Reddy died 46 years ago on July28,1976, and DV Rao died on July12, 1984. Every year in  July, meetings, small and big, are held across Telangana and" /><meta name="twitter:site" content="@Countercurrents" /><meta name="twitter:creator" content="@Countercurrents" /><meta name="twitter:image" content="https://cdn.countercurrents.org/wp-content/uploads/2022/07/TN-DV.jpg" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="MA Krishna" /><meta name="twitter:label2" content="Time to read" /><meta name="twitter:data2" content="18 minutes" /> <script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://countercurrents.org/#organization","name":"Countercurrents.org","url":"https://countercurrents.org","logo":{"@type":"ImageObject","@id":"https://countercurrents.org/#logo","url":"https://cdn.countercurrents.org/wp-content/uploads/2020/05/CC-Logo.jpg","caption":"Countercurrents.org","inLanguage":"en-US","width":"840","height":"86"}},{"@type":"WebSite","@id":"https://countercurrents.org/#website","url":"https://countercurrents.org","name":"Countercurrents.org","publisher":{"@id":"https://countercurrents.org/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://cdn.countercurrents.org/wp-content/uploads/2022/07/TN-DV.jpg","url":"https://cdn.countercurrents.org/wp-content/uploads/2022/07/TN-DV.jpg","width":"700","height":"452","inLanguage":"en-US"},{"@type":"BreadcrumbList","@id":"https://countercurrents.org/2022/07/remembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi/#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://countercurrents.org","name":"Home"}},{"@type":"ListItem","position":"2","item":{"@id":"https://countercurrents.org/life-philosophy/","name":"Life/Philosophy"}},{"@type":"ListItem","position":"3","item":{"@id":"https://countercurrents.org/2022/07/remembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi/","name":"Remembering T.Nagi Reddy, his college days in BHU and MK Gandhi"}}]},{"@type":"WebPage","@id":"https://countercurrents.org/2022/07/remembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi/#webpage","url":"https://countercurrents.org/2022/07/remembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi/","name":"Remembering T.Nagi Reddy, His College Days In BHU And MK Gandhi| Countercurrents","datePublished":"2022-07-28T11:20:49+05:30","dateModified":"2022-07-28T11:20:49+05:30","isPartOf":{"@id":"https://countercurrents.org/#website"},"primaryImageOfPage":{"@id":"https://cdn.countercurrents.org/wp-content/uploads/2022/07/TN-DV.jpg"},"inLanguage":"en-US","breadcrumb":{"@id":"https://countercurrents.org/2022/07/remembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi/#breadcrumb"}},{"@type":"Person","@id":"https://countercurrents.org/author/ma-krishna/","name":"MA Krishna","url":"https://countercurrents.org/author/ma-krishna/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/a30ca3c4fbf93064d09dec877b0043fd?s=96&amp;r=g","url":"https://secure.gravatar.com/avatar/a30ca3c4fbf93064d09dec877b0043fd?s=96&amp;r=g","caption":"MA Krishna","inLanguage":"en-US"},"worksFor":{"@id":"https://countercurrents.org/#organization"}},{"@type":"NewsArticle","headline":"Remembering T.Nagi Reddy, His College Days In BHU And MK Gandhi| Countercurrents","keywords":"Nagi Reddy","datePublished":"2022-07-28T11:20:49+05:30","dateModified":"2022-07-28T11:20:49+05:30","author":{"@id":"https://countercurrents.org/author/ma-krishna/"},"publisher":{"@id":"https://countercurrents.org/#organization"},"description":"T.Nagi Reddy died 46 years ago on July28,1976, and DV Rao died on July12, 1984. Every year in\u00a0 July, meetings, small and big, are held across Telangana and","name":"Remembering T.Nagi Reddy, His College Days In BHU And MK Gandhi| Countercurrents","@id":"https://countercurrents.org/2022/07/remembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi/#richSnippet","isPartOf":{"@id":"https://countercurrents.org/2022/07/remembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi/#webpage"},"image":{"@id":"https://cdn.countercurrents.org/wp-content/uploads/2022/07/TN-DV.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://countercurrents.org/2022/07/remembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi/#webpage"}}]}</script> <link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//use.fontawesome.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel='preconnect' href='//www.google-analytics.com' /><link href='https://cdn.countercurrents.org' rel='preconnect' /><link href='https://use.fontawesome.com' rel='preconnect' /><link href='https://www.googletagmanager.com' rel='preconnect' /><link href='https://cse.google.com' rel='preconnect' /><link href='https://translate.googleapis.com' rel='preconnect' /><link href='https://www.google-analytics.com' rel='preconnect' /><link href='https://www.google.com' rel='preconnect' /><link href='https://c.disquscdn.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Countercurrents &raquo; Feed" href="https://countercurrents.org/feed/" /><link rel="alternate" type="application/rss+xml" title="Countercurrents &raquo; Comments Feed" href="https://countercurrents.org/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Countercurrents &raquo; Remembering T.Nagi Reddy, his college days in BHU and MK Gandhi Comments Feed" href="https://countercurrents.org/2022/07/remembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cdn.countercurrents.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='font-awesome-css'  href='https://use.fontawesome.com/releases/v5.15.4/css/all.css' type='text/css' media='all' /><link rel='stylesheet' id='google-fonts-css'  href='https://cdn.countercurrents.org/wp-content/cache/autoptimize/css/autoptimize_single_3efe94d1c5a50baa9efb34bab61e3490.css?ver=1647318029' type='text/css' media='all' /> <script type="text/javascript">var dnt_config={ifdnt:"1",mode:"blacklist",black:["media6degrees.com","quantserve.com","lockerz.com"],white:[]};</script><script type='text/javascript' src='https://cdn.countercurrents.org/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script> <script defer type='text/javascript' src='https://cdn.countercurrents.org/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script> <script defer type='text/javascript' src='https://cdn.countercurrents.org/wp-content/plugins/wp-donottrack/donottrack-min.js?dntver=0.8.8&#038;ver=6.0.1' id='wp-donottrack-js'></script>  <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-166669197-1' id='google_gtagjs-js' async></script> <script type='text/javascript' id='google_gtagjs-js-after'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["countercurrents.org"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-166669197-1", {"anonymize_ip":true});</script> <link rel="https://api.w.org/" href="https://countercurrents.org/wp-json/" /><link rel="alternate" type="application/json" href="https://countercurrents.org/wp-json/wp/v2/posts/81065" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://countercurrents.org/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://countercurrents.org/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 6.0.1" /><link rel='shortlink' href='https://countercurrents.org/?p=81065' /><link rel="alternate" type="application/json+oembed" href="https://countercurrents.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcountercurrents.org%2F2022%2F07%2Fremembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi%2F" /><link rel="alternate" type="text/xml+oembed" href="https://countercurrents.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcountercurrents.org%2F2022%2F07%2Fremembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi%2F&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.79.1" /> <script type="text/javascript">document.write('<style type="text/css">.tabber{display:none;}</style>');</script> <link rel="icon" href="https://cdn.countercurrents.org/wp-content/uploads/2020/05/twitternew_400x400-55x55.jpg" sizes="32x32" /><link rel="icon" href="https://cdn.countercurrents.org/wp-content/uploads/2020/05/twitternew_400x400-300x300.jpg" sizes="192x192" /><link rel="apple-touch-icon" href="https://cdn.countercurrents.org/wp-content/uploads/2020/05/twitternew_400x400-300x300.jpg" /><meta name="msapplication-TileImage" content="https://cdn.countercurrents.org/wp-content/uploads/2020/05/twitternew_400x400-300x300.jpg" /></head><body class="post-template-default single single-post postid-81065 single-format-standard custom-background"><header id="header"><div id="menutop"><div class="inner-wrap"> <a class="btn_menu" id="toggle-top" href="#"></a><div id="topmenu-wrap"><ul id="topmenu" class="dropdown"><li id="menu-item-2003" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2003"><a href="https://countercurrents.org/fair-use-notice/">Fair Use</a></li><li id="menu-item-2004" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2004"><a href="https://countercurrents.org/disclaimer/">Disclaimer</a></li><li id="menu-item-50797" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-50797"><a href="https://countercurrents.org/privacy-policy/">Privacy Policy</a></li><li id="menu-item-2006" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2006"><a href="https://countercurrents.org/contact/">Contact</a></li><li id="menu-item-2096" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2096"><a href="https://countercurrents.org/subscription/">Subscription</a></li><li id="menu-item-2095" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2095"><a href="https://countercurrents.org/news-letter/">News Letter</a></li><li id="menu-item-2005" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2005"><a href="https://countercurrents.org/countercurrents-submission-policy/">Submission Policy</a></li><li id="menu-item-2007" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2007"><a href="https://countercurrents.org/about/">About</a></li></ul></div><div id="navsocial"><div id="lsi_widget-2" class="widget widget_lsi_widget"><h3 class="title">Social Icons</h3><ul class="lsi-social-icons icon-set-lsi_widget-2" style="text-align: left"><li class="lsi-social-facebook"><a class="" rel="nofollow noopener noreferrer" title="Facebook" aria-label="Facebook" href="https://www.facebook.com/countercurrents/" target="_blank"><i class="lsicon lsicon-facebook"></i></a></li><li class="lsi-social-twitter"><a class="" rel="nofollow noopener noreferrer" title="Twitter" aria-label="Twitter" href="https://twitter.com/countercurrents" target="_blank"><i class="lsicon lsicon-twitter"></i></a></li><li class="lsi-social-youtube"><a class="" rel="nofollow noopener noreferrer" title="YouTube" aria-label="YouTube" href="https://www.youtube.com/user/CCMEDIACHANNEL" target="_blank"><i class="lsicon lsicon-youtube"></i></a></li><li class="lsi-social-rss"><a class="" rel="nofollow noopener noreferrer" title="RSS" aria-label="RSS" href="https://countercurrents.org/feed/" target="_blank"><i class="lsicon lsicon-rss"></i></a></li></ul><div class="clear"></div></div></div><div class="clear"></div></div></div><div id="header-widget-area" class="chw-widget-area widget-area" role="complementary"><div class="widget_text chw-widget"><h2 class="chw-title"><div class="empty"></div></h2><div class="textwidget custom-html-widget"> <a style="background: #9a6400;" href="https://countercurrents.org/covidresponsewatch/"> <img class="center" src="https://cdn.countercurrents.org/wp-content/uploads/2016/06/COVID-Banner.jpg" alt="COVID Response Watch"></a></div></div></div><div class="inner-wrap header-wrap"><div id="logo"> <a href="https://countercurrents.org" title="Educate | Organize | Agitate"> <img src="https://cdn.countercurrents.org/wp-content/uploads/2016/06/logo-1-4.png" alt="Countercurrents" /> </a></div><div class="clear"></div><div id="menu"> <a class="btn_menu" id="toggle-main" href="#"></a><div id="menu-wrap"><ul id="mainmenu" class="dropdown"><li id="menu-item-66581" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66581"><a href="https://countercurrents.org/india/">India</a></li><li id="menu-item-66580" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66580"><a href="https://countercurrents.org/world/">World</a></li><li id="menu-item-66619" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66619"><a href="https://countercurrents.org/covidresponsewatch/">COVID Response Watch</a></li><li id="menu-item-66583" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66583"><a href="https://countercurrents.org/human-rights/">Human Rights</a></li><li id="menu-item-66584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66584"><a href="https://countercurrents.org/arts-literature/">Arts/Literature</a></li><li id="menu-item-66585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66585"><a href="https://countercurrents.org/imperialism/">Imperialism</a></li><li id="menu-item-66586" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66586"><a href="https://countercurrents.org/climate-change/">Climate Change</a></li><li id="menu-item-66711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66711"><a href="https://countercurrents.org/palestine/">Palestine</a></li></ul></div><div class="clear"></div></div></div></header><div class="container"><div class="content-wrap"><div class="single-area"><div class="post-meta"><h1 class="title"> <a href="https://countercurrents.org/2022/07/remembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi/" title="Permalink to Remembering T.Nagi Reddy, his college days in BHU and MK Gandhi" rel="bookmark">Remembering T.Nagi Reddy, his college days in BHU and MK Gandhi</a></h1> in <a href="https://countercurrents.org/life-philosophy/" rel="category tag">Life/Philosophy</a> <span class="separator">&mdash;</span> by <a href="https://countercurrents.org/author/ma-krishna/" title="Posts by MA Krishna" rel="author">MA Krishna</a> <span class="separator">&mdash;</span> 28/07/2022</div><div id="post-81065" class="clearfix post-wrap post-81065 post type-post status-publish format-standard has-post-thumbnail hentry category-life-philosophy tag-dv-rao tag-t-nagi-reddy"><div class="entry"><div class="scriptlesssocialsharing"><h3 class="scriptlesssocialsharing__heading">Share:</h3><div class="scriptlesssocialsharing__buttons"><a class="button whatsapp" target="_blank" href="https://api.whatsapp.com/send?text=Remembering%20T.Nagi%20Reddy%2C%20his%20college%20days%20in%20BHU%20and%20MK%20Gandhi%20%E2%80%94%20https%3A%2F%2Fcountercurrents.org%2F2022%2F07%2Fremembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi%2F" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>WhatsApp</span></a><a class="button facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fcountercurrents.org%2F2022%2F07%2Fremembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi%2F" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Facebook</span></a><a class="button twitter" target="_blank" href="https://twitter.com/intent/tweet?text=Remembering%20T.Nagi%20Reddy%2C%20his%20college%20days%20in%20BHU%20and%20MK%20Gandhi&#038;url=https%3A%2F%2Fcountercurrents.org%2F2022%2F07%2Fremembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi%2F&#038;via=countercurrents&#038;related=countercurrents" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Twitter</span></a><a class="button telegram" target="_blank" href="https://telegram.me/share/url?url=https%3A%2F%2Fcountercurrents.org%2F2022%2F07%2Fremembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi%2F&#038;text=Remembering%20T.Nagi%20Reddy%2C%20his%20college%20days%20in%20BHU%20and%20MK%20Gandhi" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Telegram</span></a><a class="button reddit" target="_blank" href="https://www.reddit.com/submit?url=https%3A%2F%2Fcountercurrents.org%2F2022%2F07%2Fremembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi%2F" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Reddit</span></a><a class="button email" href="mailto:?body=I%20read%20this%20post%20and%20wanted%20to%20share%20it%20with%20you.%20Here%27s%20the%20link%3A%20https%3A%2F%2Fcountercurrents.org%2F2022%2F07%2Fremembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi%2F&#038;subject=A%20post%20worth%20sharing%3A%20Remembering%20T.Nagi%20Reddy%2C%20his%20college%20days%20in%20BHU%20and%20MK%20Gandhi" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Email</span></a></div></div><p style="text-align: center;"><noscript><img class="aligncenter size-full wp-image-81066" src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/TN-DV.jpg" alt="TN DV" width="700" height="452" srcset="https://cdn.countercurrents.org/wp-content/uploads/2022/07/TN-DV.jpg 700w, https://cdn.countercurrents.org/wp-content/uploads/2022/07/TN-DV-300x194.jpg 300w" sizes="(max-width: 700px) 100vw, 700px" title="Remembering T.Nagi Reddy, his college days in BHU and MK Gandhi 1"></noscript><img class="lazyload aligncenter size-full wp-image-81066" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20700%20452%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/TN-DV.jpg" alt="TN DV" width="700" height="452" data-srcset="https://cdn.countercurrents.org/wp-content/uploads/2022/07/TN-DV.jpg 700w, https://cdn.countercurrents.org/wp-content/uploads/2022/07/TN-DV-300x194.jpg 300w" data-sizes="(max-width: 700px) 100vw, 700px" title="Remembering T.Nagi Reddy, his college days in BHU and MK Gandhi 1"></p><p>   <strong><em>A memorial meeting, remembering Com DV and TN was held in Khammam town of Telangana State on July27, 2022.</em></strong></p><p><em>Hundreds of people who are fighting for and supporting agrarian revolution attended, including a big number of adivasi and poor peasants, and large number of women. The meeting held  in the peak of rainy season went on from10.30 am to 5pm (with 30-minute lunch-break), speakers explaining the revolutionary politics, current politics and ongoing struggles. Far left are adivasi and poor pesant leaders, Muttayya and veteran fighter Padiga Yerraiah (President  of  Grameena  Pedala Sangham of rural poor). Far right is Dr. Jatin Kumar, OPDR leader from Telangana.   </em></p><p><em>Currently struggles of adivasi and poor and landless peasants for  podu (forest lands),who occupied and tilled thousands of acres and demanding pattas (legal rights) as per Forest Rights Act , 2006,are going on in various parts of Telangana. </em></p><p><em>Speakers  asked if the newly-elected  President Draupadi  Murmu, born and projected by Modi-led BJP as adivasi herself will stand by the rural poor fighting for their  land and democratic rights.  </em></p><p><em>T.Nagi Reddy died 46 years ago on July28,1976, and DV Rao died on July12, 1984. Every year in  July, meetings, small and big, are held across Telangana and Andhra Pradesh by UCCRI-ML remembering the revolutionary mass line they founded, and reviewing struggles along  that line. The above is one such well-attended meeting (see photos below)  </em></p><p><strong><em>countercurrents.org</em></strong> has a rich archive on the lives and work of Comrades TN and DV: see at the end of the article for more.  <em> </em></p><p><em>***                         ***</em></p><p><em>July 28, 1976 was the day when  veteran communist revolutionary leader Com TN(1917-1976), as he was called, died of a sudden illness when he was not even 60. It was the period of  Internal Emergency  proclaimed (on 1975 June 26)  by Mrs. Indira Gandhi’s regime, a watershed in India’s  political history. He along with his comrade-associate  DV Rao(1917-1984July12) known for his stellar role in Telangana People’s Armed Struggle 1946-51) had jumped bail—they were earlier  convicted by a Special Court on <strong>charges of Conspiracy and Sedition</strong> to overthrow the Govt, and went in Appeal to the High Court of Andhra Pradesh against the verdict –and slipped into underground life in July 1975. </em></p><p><strong><em>The UCCRI (ML) was co-founded by them in April 1975 only to be banned  three months later by the Govt in July 1975. They were trying to cope with the new situation of Constitutional autocracy</em></strong><em> when TN got into a  sudden, brief  illness and died incognito in Osmania General Hospital, Hyderabad, on July 28. It is 46 years since he died but TN and DV are remembered every year in meetings held in Andhra Pradesh and Telangana , where their  revolutionary mass line is pursued, with a thrust on agrarian revolution, as part of people’s democratic revolution aimed against imperialism, big-comprador bourgeoisie and landlord classes. </em></p><p style="text-align: center;"><noscript><img class="aligncenter size-full wp-image-81067" src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/aud.jpg" alt="aud" width="730" height="251" srcset="https://cdn.countercurrents.org/wp-content/uploads/2022/07/aud.jpg 730w, https://cdn.countercurrents.org/wp-content/uploads/2022/07/aud-300x103.jpg 300w" sizes="(max-width: 730px) 100vw, 730px" title="Remembering T.Nagi Reddy, his college days in BHU and MK Gandhi 2"></noscript><img class="lazyload aligncenter size-full wp-image-81067" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20730%20251%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/aud.jpg" alt="aud" width="730" height="251" data-srcset="https://cdn.countercurrents.org/wp-content/uploads/2022/07/aud.jpg 730w, https://cdn.countercurrents.org/wp-content/uploads/2022/07/aud-300x103.jpg 300w" data-sizes="(max-width: 730px) 100vw, 730px" title="Remembering T.Nagi Reddy, his college days in BHU and MK Gandhi 2"></p><p><em>***                                          ***</em></p><p>&nbsp;</p><p><strong>Com TN, his college days in BHU, Gandhi and Nehru</strong></p><p><em>The following are excerpts from an interview given by comrade TN, 1975, </em><em>June-July, one year before he died on July 28, 1976. </em><em>Some incidents of </em><em>Comrade TN&#8217;s college life are covered  here. They are of interest as India celebrates its Azadi ka Amrit mahotsav, 75years of independence. Idelogical struggle between the Left and communist students and the communal RSS wing in BHU feature in this story, reported by the then media leaders,  Gandhian Indian Express versus Nehruite National Herald</em><strong><em>, </em></strong><em>taking sides.<strong>  </strong></em></p><p><strong><em>Now the Text of the interview follows: </em></strong></p><p><strong>Any details of your life in LoyolaCollege, ( Chennai) for two years?</strong></p><p>Yes. Not happy but quite bitter. On the very first day of class, the opening of the College, I had a small clash with the very first Professor that came to address my class. As a student of Theosophical and Rishivalley Schools, I was not in the habit of artificial respectfulness to any Professor or teacher. With the result that it did not enter my head that I should stand up when a Professor enters the class-room. Not being in that habit, I failed to notice the others standing when the Professor entered the class-room. 1 was admonished for it. I was asked as to where I had studied previously. When I told them that I came from Theosophical and Rishi Valley, the Professor very curtly said to me that I should learn better manners from now onwards. Therefore my very first impression of the college was not favourable to them. From then on, I had serious clashes, sometimes open, sometimes implied, with the administration of the college.</p><p><strong>I </strong><strong>was fined quite a number of times, for such reasons as having attended a public </strong><strong>meeting addressed by Jawaharlal Nehru,</strong> for having participated in that famous Satya Murthy versus Ramaswamy Mudaliyar election campaign, and for producing some essays of history , which were not in conformity with the teaching of the Professors. One instance stands out which would have had an extremely voracious effect if I had bowed down to them.</p><p><strong>Essay on Mohammad Bin Tughlak</strong></p><p>During the second year of the College life, i.e., Intermediate (1932-33), the class was asked to write an essay on Mohammad Bin Tughlak during the holidays. I was angry when the Professor used to make harsh remarks that Mohammad Bin Tughlak was mad. As a Nationalist at that time, I was not prepared to take their verdict as correct. Therefore, I purchased quite a number of books relating to that historical period and with the help of  Eswar Prasad&#8217;s <em>Medieval History of India</em>, I produced an essay characterising Mohammad Bin Tughlak as a man of genius, born long before the times, establishing the fact that he was a great economist and therefore produced coins in leather and not in metal (historically criticising the paper currency now in vogue), characterising him as a military genius of having thought of transferring the capital of India from Delhi which is prone to attacks from outsiders to a place more centrally situated. Therefore less attacks from enemies,  along with quite number of other important characteristics of Mohammad Bin Tughlak to explain and naturally that he was a genius and not  mad as imperialist historians have distorted. Having gone through that essay, he criticised me in the class and asked me to produce a different essay as per the teaching in the class. I refused, therefore I was fined Rs. 507. I have made a report to my father (who was a Congress leader of  Andhra’s  Anantpur dt., then part of composite Madras province) ahead of a report from Father Vian, the Principal. My father wrote a letter to the administration saying that the boy is never indisciplined as they have called him and that he is sending Rs. 50/- by Money Order  to clear the fine that has been imposed on me. That is only one of the many instances that occurred during that period.</p><p><strong>Jawaharlal Nehru&#8217;s </strong><strong>public meeting</strong></p><p><em>Any other instance?</em></p><p>There is one more instance at Loyola. I was one of those students who kept very meticulously to the discipline of the college. After the college hours, we were expected back in the hostel by 9 p.m. In between that period, i.e., 5-00 p.m after the college is closed and 9 p.m., we had certain amount of freedom to move about. One day I had gone to the Marina Beach to hear Jawaharlal Nehru&#8217;s address in a public meeting. Remembering the college discipline I left the meeting even before it was over to be back again in the hostel in time. Catholic Wardens, knowing that Jawahar Lal Nehru will certainly attract a few of the nationalist-minded students in the hostel, kept vigilance over our activities. They asked me as to where I had been. I truthfully told them that I had attended the public meeting addressed by Jawaharlal Nehru. Immediately a fine was imposed. The others who had come along with me had escaped the fine because they told the Principal that they had been to the first show of a picture. Such instances as these angered me to a certain extent that I was in a half mind to leave the college immediately. But my father convinced me by telling me that I need not bother as to what the authorities do in relation to my activities which were not in any way hindering my studies in the college and violating the discipline of the college. With this experience I decided that I would no more enter that college again after examinations. With the result that my next college life began in Benarus Hindu University. In Loyola College I was not permitted to have my &#8216;Charka&#8217; in my room.</p><p><strong>Benarus Hindu University</strong><strong> where Communists and terrorists had a place</strong></p><p><em>Who advised you to go to Benarus Hindu University?</em></p><p>1 should say none. As a matter of fact even when I went to Loyola College, I was interested in going to Benarus but then my father came in my way and promised to send me to Benarus after completing my Intermediate, and of the colleges in Madras, I was told at that time, that Loyola was one of the very best, but then I had not known that Loyola was so anti-national in its activities.</p><p><strong><em>What were your first impressions of the Benarus Hindu University?</em></strong></p><p>I do not remember any now.</p><p><strong><em>Do you remember any of your lecturers there?</em></strong></p><p>Yes, a few of them.</p><p><strong>Do you remember Achyut Patwardhan?</strong></p><p>No.</p><p>I remember Prof. Gurumukh Nihal Singh of the Politics Department, Prof. Mukid Bihar Lai, Politics Dept, Prof. BP Adarkar of Economics Dept., Prof. Aswani, Department of Physics, Warden of &#8216;A Block, (Hostel), Dr. C. N. Menon of English Department and Prof. Subramanyam of the Law College. Benarus Hindu University was responsible for completely re-orienting my political and economic views. Probably it was the greatest turning point in my personal and political life. It was the place which produced quite a number of friendships which remained last to this day. It served to help me study seriously various political and economic theories to finally come to the conclusion at the fag end of my study in Benarus that <strong>Communism and Communist Party alone can save </strong><strong>this country from the Imperialist exploitation.</strong></p><p>Benarus Hindu University was at that time a place wherein all politically-oriented students from various parts of the country belonging to various political philosophies and parties gathered together, both to complete their academic studies and also to gain nationalised political knowledge. Benarus Hindu University of that period was a political centre wherein leaders of various parties openly and surreptitiously made the students interested in political activities and that way it was a centre of activity of different views of nationalist movements in our country. Gandhists, Nehruists, Congress Socialists, Communists and Terrorists had a place in that University.</p><p><strong>Gandhian TN turned Communist</strong></p><p>Leaders of all these parties openly and secretly (as in the case of Communists and Terrorists) visited the University very often. It was an experience, which probably is not available today in any place in our country. At that period students of various political philosophies had an extremely bitter controversial discussions on various aspects of political life. Polemics was the order of the day. At the time of entering the University, I was a convinced Gandhist. On my way to Benarus Hindu University along with Mr. Kalluri Subba Rao, who was one of the doyens of the political leaders of our State, visited Sevagram near Wardha to see Gandhiji. From the Ashram I had even a Charka to Benarus Hindu University to continue my spinning. So I entered Benarus Hindu University as a convinced Gandhist,  and during the four or five years I studied there, I was influenced by the Congress Socialists namely Kamaladevi Chattopadhyaya, Jaya Prakash Narayan, Achyut Patwardhan and others, and from there on to the Communist party in course of time. It was in Benarus Hindu University that I came to know of Marx and Marxism, it was in Benarus Hindu University that I came to understand the importance of the Russian Revolution and its political leadership of Lenin and Stalin, it was in Benarus Hindu University that for the first time I came to know that Marxism can be applied to Indian conditions. Surprisingly Jaya Prakash Narayan&#8217;s socialism played an important role in understanding this aspect. Later Jawaharlal Nehru&#8217;s address to the Lucknow Congress wherein he made specific mention of the treatises of <strong><em>Soviet Communism</em></strong>, written by famous Sydney and Beatrice   Webbs, almost finally completed the process of transmission from Gandhism to Communism. It was during this period, that I came into personal contact with two of my student friends, S.P. Tripathi and Rustum Satin, who helped me to get certain literature of the Communist Party to go through. It was during this period that Comrade Bharadwaj, who was a responsible Communist leader, in charge of the student unit in Banarus, came into contact with us. It was again during this period that I was lead to read quite a number of books produced by Left Books Club of London, especially those by John Strachy &#8211; <strong><em>Theory &amp; Practice of Socialism</em></strong>, &#8216;The coming struggle for power&#8217; — and Palme Dutt, especially his classical book <strong><em>&#8216;World Politics&#8217;.</em></strong></p><p>The Spanish Civil War, one of the most important international incidents that took place during that period played an extremely significant role on the minds of the youth of the day. The self-sacrificing role of the Communists in that Civil War influenced me at that time. Added to all this, there was an important Telugu personality in the University, Kalipatnapu Kondaiah, M.Sc., Prof of Chemistry; he in his own silent manner influenced me in my study to understand world politics in a scientific process. During this period our political life was extremely active, undergoing a series of changes analysing every aspect of the Nationalist movement in a manner which probably never took place later. Quite a number of old concepts were demolished here. Benarus Hindu University was a politically strong centre during the period which did create and extend new political horizons.</p><p><strong>As the President of   BHU’s </strong><strong>Students&#8217; Association </strong></p><p><em>Why were you thrown out of the University?</em></p><p>In 1939 I happened to be the President of the Benarus Hindu University Students&#8217; Association, the first Andhra to be elected. During that period national upsurge among the students was growing. The Congress had passed a resolution demanding a Constituent Assembly. There was quite a hectic political life mainly on the question of the Constituent Assembly itself.</p><p>Sir Marz Grower, Vice-chancellor of the Delhi University, was invited to deliver the Convocation Address in Benarus Hindu University. We, on behalf of the Students Union, had opposed the invitation to him by the University on the ground that he would deliver an address which would against our National sentiments. We had given a call for the boycott of the Convocation by the students. <strong>Dr. Radha Krishnan (later the President of India) </strong><strong>was the then Vice Chancellor </strong>of Benarus Hindu University. Seeing that our call had a great impact on the students, he contacted us, and told us that it was not his invitation that was responsible for Sri Marz Grower&#8217;s visit to the University but that Gandhiji recommended his name for the same. Therefore, he requested us that we should withdraw the appeal for boycott of the Convocation. On an understanding with him that Sir Marz Grower would not transgress into fields which would hurt the national sentiments of the students community during the course of the Convocation Address, we on our part withdrew our appeal to the students to boycott the Convocation. So the Convocation took place peacefully. Taking advantage of the situation, Sir Marz Grower came out very strongly against the slogan of the Constituent Assembly with quite a number of historical untruths. This naturally angered us. Immediately after the Convocation address <strong>we produced an extremely educative leaflet on Constituent Assembly</strong> putting forth the historical data that Constituent Assemblies in world history had played an extremely important role in various revolutions, including the American Revolution. I, as the President of the Students Union, had signed the leaflet which was issued under my name. This leaflet was posted to Sir Marz Grower with a personal letter from me as the President of the Students Union requesting him to accept a challenge to discuss pros and cons of constituting a Constituent Assembly for India in any place he likes, at any time he wishes, but within the period of 2 months. If he fails to convey his consent within a matter of 15 days (If remember correct), we told him that we would call for a general strike of the students in protest against the unseemly manner in which he used a platform consciously to deride the most important slogan of the National movement at the time.</p><p><strong>Gandhiji sought </strong><strong>an apology</strong></p><p>Sir Marz Grower on his part sent this letter along with the leaflet to Mahatma Gandhi. Gandhiji on his part directed that letter, along with a request of his own to get an apology from us,  to Dr. Radhakrishnan. In the meantime, since 15 days of the time allotted was over, we issued a call to the students to go on strike in protest against Sir Marz Grower&#8217;s behaviour during the convocation. Dr. Radhakrishnan contacted me again and showed me the letter that Gandhiji had written. <strong>We were naturally perturbed at the attitude of Mahatmaji himself.</strong></p><p>We asked Dr. Radhakrishnan as to what exactly the mistake we committed. We told him that after all ours was an academic challenge to put the historical truth in its proper perspective. Therefore the question of apology does not arise. But Radhakrishnan&#8217;s contention was that Gandhiji had been hurt that a guest had been insulted by the challenge. Then on behalf of the Students Union I had given in writing to Dr. Radhakrishnan that we, the Executive Committee of the Students Union, are extremely sorry for having hurt the feelings of Mahatmaji, even though <em>our leaflet was in fact nothing but enunciation of truth</em> in relation to the declaration of an untruth by Dr. Marz Grower.</p><p><strong>Gandhian<em> Indian </em></strong><strong><em>Express Vs </em></strong><strong>Nehruite </strong><strong><em>National Herald</em></strong></p><p>During this period, <strong><em>Indian </em></strong><strong><em>Express</em></strong> from Madras had written in one of its comments that the President of the Students Union, i.e., me, had taken such an unhealthy attitude, that unless he is disciplined, student community in general would be behaving in such indisciplined manner. This is a call for action against me. Immediately after this, the <strong><em>National Herald</em></strong> from Lucknow (Nehru&#8217;s paper) warned the University authorities that any action against the President of the Student Union will only mean large scale action, not only by the students of the Benaras Hindu University but by the students of all Universities. <strong>Dr. Radhakrishnan, being an astute administrator, left the matters at that stage. </strong></p><p><strong>Strike in BHU that was 100% successful</strong></p><p>But the Principal of the Law College, Mr. Subramanyam, entered at this stage. He one day called me to the office and warned me that unless the strike is withdrawn, serious action will be taken against me. I told him the call for strike has been given by the Students Union, of which Nagi Reddy is only one amongst many. It was at this stage he threatened me that it would be difficult for me to successfully complete my studies. Later the strike took place which was 100% successful. <strong>With the intervention of Dr. </strong><strong>Radhakrishnan again, no action was taken against me,</strong> but it so happened that I could not complete my law successfully as per the threat of <strong>Principal Mr. </strong><strong>Subrahmanyam. He has failed me in his Hindu Law paper.</strong> On the day that I left the University after the results were announced, I met Mr. Subrahmanyam and told him that I am no more interested in completing my law since my life has taken a new turn. That is how my studies came to a close in the Benarus Hindu University.</p><p><em>When did you become a card holder of the Communist Party of India?</em></p><p>1939 at Benarus.</p><p>Was <em>Batliwala the person who converted you into a Communist ?</em></p><p>No. It was mainly Bharadwaj, who was then the member of the Central Committee of the Communist Party and the Member of the A.I.C.C.</p><p><strong>BHU Students led by TN supported the Spanish Civil War</strong></p><p>The RSS in Benarus Hindu University was an extremely powerful and important factor. They had an extremely well disciplined organisation in the University, but their influence amongst the students was not much. The students union was highly popular. It led the political discussions amongst the students to organise and mobilise them not only for the students&#8217; demands but also on national issues and sometimes even on certain international issues such as the Spanish Civil War.</p><p><strong>Some thousands of rupees were collected from amongst the students by </strong><strong>the Students Union to help the Left forces in the Spanish Civil War and was sent through Jawaharlal Nehru.</strong></p><p><strong>RSS student youth </strong><strong> in the communal riots</strong> Vs  <strong>Leftist</strong> <strong>students union</strong></p><p>But RSS was  capable of mobilising their disciplined, organised youth for various purposes, especially when there is communal trouble. It so happened that in 1939-40, serious communal Hindu-Muslim riots took place in Benarus. <strong>RSS mobilised its youth (student youth) from the University </strong><strong>in the name of safeguarding the Hindu property to directly participate in the communal riots.</strong></p><p><em>In safeguarding the students from the communal riots, the students union almost barricaded the University and kept vigilance day and night to see that communal elements neither go out of the University nor get into the University.</em></p><p>Even so some of the students under the leadership of the RSS did participate in the communal riots, with the result that two students were killed. There was a huge protest made to Pandit Madan Mohan Malavya for having allowed the RSS to function in the University with all its communal programme being disseminated within the students. It was at that time that the <strong>RSS boys of Benarus Hindu University put up posters that Students Union will be buried and its President (myself) will be hanged to the nearest post.</strong></p><p><em>Even though RSS was given complete freedom in the University</em> <em>for all its activities, one should remember the strength of the RSS in Benarus Hindu University at that time amongst the students was almost negligible.</em></p><p><strong><em>MA Krishna, a media person, frequently contributed to countercurrents.org </em></strong></p><p>(The Interview, Courtesy: <em>The Proletarian Line, </em>Issue No. 42, February-March 1984.  It is the Organ of Communist Revolutionaries published from  Hyderabad, founded and then edited by DVRao).</p><p><em>***                ***</em></p><p><strong><em>countercurrents.org</em></strong> has a rich archive on the lives and work of Comrades TN and DV, including the following articles.</p><p><strong>Tarimela Nagi Reddy Remembered</strong>, 28/07/2016</p><p><a href="https://countercurrents.org/2016/07/tarimela-nagi-reddy-remembered/">https://countercurrents.org/2016/07/tarimela-nagi-reddy-remembered/</a></p><p><strong>Comrade DV Rao: Unique Role In  Indian Communist Movement, </strong>12/07/2020</p><p><a href="https://countercurrents.org/2020/07/comrade-dv-rao-unique-role-in-indian-communist-movement/">https://countercurrents.org/2020/07/comrade-dv-rao-unique-role-in-indian-communist-movement/</a></p><div class="awac-wrapper"><div class="awac widget text-4"><h4 class="widget-title"><div class="empty"></div></h4><div class="textwidget"><hr /><p>Countercurrents is answerable only to our readers. Support <strong><a href="https://countercurrents.org/subscription">honest journalism </a></strong> because we have no PLANET B. Subscribe to our <strong><a href="https://t.me/countercurrentsorg" target="_blank" rel="nofollow noopener">Telegram channel</a></strong></p><hr /><p><strong><a href="https://countercurrents.org/news-letter" data-wpel-link="internal">GET COUNTERCURRENTS DAILY NEWSLETTER STRAIGHT TO YOUR INBOX</a></strong></p><hr /></div></div></div><div class="relpost-thumb-wrapper"><div class="relpost-thumb-container"><h3>Related posts:</h3><div style="clear: both"></div><div style="clear: both"></div><div class="relpost-block-container"><a href="https://countercurrents.org/2021/08/70244/" class="relpost-block-single"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt="On The Question Of Political Independence –Part 2" style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2019/07/DV-Rao-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;">On The Question Of Political Independence –Part 2</div></div></a><a href="https://countercurrents.org/2021/07/a-tribute-to-communist-revolutionary-comrade-t-nagi-redddy/" class="relpost-block-single"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt="A Tribute to Communist Revolutionary Comrade T. Nagi Redddy" style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2021/07/DV-Rao-T-Nagi-Reddy-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;">A Tribute to Communist Revolutionary Comrade T. Nagi Redddy</div></div></a><a href="https://countercurrents.org/2021/07/china-communist-party-was-always-a-controversy-part-2/" class="relpost-block-single"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt="China Communist Party Was Always A Controversy –Part-2" style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2021/07/Mao-Deng-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;">China Communist Party Was Always A Controversy –Part-2</div></div></a><a href="https://countercurrents.org/2021/07/china-communist-party-was-always-a-controversy-before-and-after-its-revolution-before-and-after-mao-comrade-dv-rao/" class="relpost-block-single"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt="China Communist Party Was Always A Controversy, Before And After Its Revolution, Before And After Ma..." style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2016/07/dvrao-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;">China Communist Party Was Always A Controversy, Before And After Its Revolution, Before And After Ma...</div></div></a><a href="https://countercurrents.org/2021/07/dv-rao-remembered-on-his-37th-death-anniversary/" class="relpost-block-single"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt="DV Rao Remembered On His 37th Death Anniversary" style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2020/07/DV-Rao-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;">DV Rao Remembered On His 37th Death Anniversary</div></div></a><a href="https://countercurrents.org/2021/02/tribute-to-tarimela-nagi-reddy-on-104th-birthday-today/" class="relpost-block-single"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt="Tribute to Tarimela Nagi Reddy on 104th birthday today" style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2021/02/Nagi-Reddy-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;">Tribute to Tarimela Nagi Reddy on 104th birthday today</div></div></a><a href="https://countercurrents.org/2021/01/dv-rao-on-indias-constitutional-system-part-2/" class="relpost-block-single"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt="DV Rao on  India’s Constitutional System (Part-2)" style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2016/07/dvrao-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;">DV Rao on  India’s Constitutional System (Part-2)</div></div></a><a href="https://countercurrents.org/2021/01/dv-rao-on-constitutional-system/" class="relpost-block-single"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt="DV Rao on Constitutional System" style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2016/07/dvrao-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;">DV Rao on Constitutional System</div></div></a></div><div style="clear: both"></div></div></div><div class="scriptlesssocialsharing"><h3 class="scriptlesssocialsharing__heading">Share:</h3><div class="scriptlesssocialsharing__buttons"><a class="button whatsapp" target="_blank" href="https://api.whatsapp.com/send?text=Remembering%20T.Nagi%20Reddy%2C%20his%20college%20days%20in%20BHU%20and%20MK%20Gandhi%20%E2%80%94%20https%3A%2F%2Fcountercurrents.org%2F2022%2F07%2Fremembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi%2F" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>WhatsApp</span></a><a class="button facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fcountercurrents.org%2F2022%2F07%2Fremembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi%2F" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Facebook</span></a><a class="button twitter" target="_blank" href="https://twitter.com/intent/tweet?text=Remembering%20T.Nagi%20Reddy%2C%20his%20college%20days%20in%20BHU%20and%20MK%20Gandhi&#038;url=https%3A%2F%2Fcountercurrents.org%2F2022%2F07%2Fremembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi%2F&#038;via=countercurrents&#038;related=countercurrents" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Twitter</span></a><a class="button telegram" target="_blank" href="https://telegram.me/share/url?url=https%3A%2F%2Fcountercurrents.org%2F2022%2F07%2Fremembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi%2F&#038;text=Remembering%20T.Nagi%20Reddy%2C%20his%20college%20days%20in%20BHU%20and%20MK%20Gandhi" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Telegram</span></a><a class="button reddit" target="_blank" href="https://www.reddit.com/submit?url=https%3A%2F%2Fcountercurrents.org%2F2022%2F07%2Fremembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi%2F" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Reddit</span></a><a class="button email" href="mailto:?body=I%20read%20this%20post%20and%20wanted%20to%20share%20it%20with%20you.%20Here%27s%20the%20link%3A%20https%3A%2F%2Fcountercurrents.org%2F2022%2F07%2Fremembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi%2F&#038;subject=A%20post%20worth%20sharing%3A%20Remembering%20T.Nagi%20Reddy%2C%20his%20college%20days%20in%20BHU%20and%20MK%20Gandhi" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Email</span></a></div></div><div class="clear"></div><div class="clear"></div></div><div class="clear"></div><div class="tag_list">Tags: <a href="https://countercurrents.org/tag/dv-rao/" rel="tag">DV Rao</a>, <a href="https://countercurrents.org/tag/t-nagi-reddy/" rel="tag">T Nagi Reddy</a></div></div><div class="post_author"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/a30ca3c4fbf93064d09dec877b0043fd?s=70&#038;r=g' srcset='https://secure.gravatar.com/avatar/a30ca3c4fbf93064d09dec877b0043fd?s=140&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2070%2070%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/a30ca3c4fbf93064d09dec877b0043fd?s=70&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/a30ca3c4fbf93064d09dec877b0043fd?s=140&#038;r=g 2x' class='lazyload avatar avatar-70 photo' height='70' width='70' /> <span>Author: <a href="https://countercurrents.org/author/ma-krishna/" title="Posts by MA Krishna" rel="author">MA Krishna</a></span><p></p><div class="clear"></div> <span class="author_links"><ul><li>Visit Author:</li><li><a href="https://countercurrents.org/author/ma-krishna/">All Posts</a></li></ul> </span></div><div class="clear"></div><div class="post-wrap"><div id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/07/remembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi/#respond" style="display:none;">Cancel</a></small></h3><form action="https://countercurrents.org/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="35" rows="5" aria-required="true" class="required" placeholder="Message"></textarea></p><div class="clear"></div><div class="form_fields"><p class="comment-form-author"><label for="author">Your Name</label> <input id="author" name="author" type="text" value="" size="30" aria-required='true' placeholder="Your Name" class="required" /><span class="required_lab">*</span></p><p class="comment-form-email"><label for="email">Your Email</label> <input id="email" name="email" type="text" value="" size="30" aria-required='true' placeholder="Your Email" class="required email" /><span class="required_lab">*</span></p><p class="comment-form-url"><label for="url">Your Website</label> <input id="url" name="url" type="text" value="" size="30" aria-required='true' placeholder="URL" /></p></div><div class="clear"></div><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='81065' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="4c8065fa90" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="117"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form></div></div></div></div><div id="sidebar"><div id="custom_html-2" class="widget_text widget widget_custom_html"><h3 class="title"><div class="empty"></div></h3><div class="widget-content"><div class="textwidget custom-html-widget"><script async src="https://cse.google.com/cse.js?cx=009660411210412073649:WMX1323034037"></script> <div class="gcse-search"></div></div><div class="clear"></div></div></div><div id="media_image-3" class="widget widget_media_image"><h3 class="title"><div class="empty"></div></h3><div class="widget-content"><a href="https://countercurrents.org/subscription/"><img width="300" height="98" src="https://cdn.countercurrents.org/wp-content/uploads/2019/05/annual-Subscription-button-300x98.jpg" class="image wp-image-38371  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://cdn.countercurrents.org/wp-content/uploads/2019/05/annual-Subscription-button-300x98.jpg 300w, https://cdn.countercurrents.org/wp-content/uploads/2019/05/annual-Subscription-button-168x55.jpg 168w, https://cdn.countercurrents.org/wp-content/uploads/2019/05/annual-Subscription-button.jpg 327w" sizes="(max-width: 300px) 100vw, 300px" /></a><div class="clear"></div></div></div><div id="text-3" class="widget widget_text"><h3 class="title">Join Our Newsletter</h3><div class="widget-content"><div class="textwidget"><form method="post" action="https://scripts.dreamhost.com/add_list.cgi"> <input type="hidden" name="list" value="editor" /> <input type="hidden" name="domain" value="https://countercurrents.org" /> <input type="hidden" name="url" value="SubscribedURL" /> <input type="hidden" name="unsuburl" value="UnsubscribedURL" /> <input type="hidden" name="alreadyonurl" value="AlreadyOnURL" /> <input type="hidden" name="notonurl" value="NotOnURL" /> <input type="hidden" name="invalidurl" value="InvalidURL" /> <input type="hidden" name="emailconfirmurl" value="EmailConfirmURL" /> <input type="hidden" name="emailit" value="1" /><div> <label for="name">Name: </label> <input type="text" name="name"></div><div> <label for="email">Email: </label> <input type="text" name="email" placeholder="Enter a valid email" required></div> </br><div class="button"> <input type="submit" name="submit" value="Join Our Announcement List"></div></form></div><div class="clear"></div></div></div><div id="wpzoom-feature-posts-2" class="widget feature-posts"><h3 class="title">Latest</h3><div class="widget-content"><ul class="feature-posts-list"><li><a href="https://countercurrents.org/2022/07/mexicos-president-gives-joe-biden-a-big-history-lesson/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2018/07/Manuel-Lopez-Obrador-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2018/07/Manuel-Lopez-Obrador-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/mexicos-president-gives-joe-biden-a-big-history-lesson/">Mexico’s President Gives Joe Biden a Big History Lesson</a> <br /><small><a href="https://countercurrents.org/author/rodrigo-guillot/" title="Posts by Rodrigo Guillot" rel="author">Rodrigo Guillot</a> | 28/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/washington-is-the-problem-not-the-solution-why-mahmoud-abbas-is-seeking-new-powerful-sponsors/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2018/02/Abbas-UN-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2018/02/Abbas-UN-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/washington-is-the-problem-not-the-solution-why-mahmoud-abbas-is-seeking-new-powerful-sponsors/">Washington is the Problem, Not the Solution: Why Mahmoud Abbas is Seeking New ‘Powerful’ Sponsors</a> <br /><small><a href="https://countercurrents.org/author/dr-ramzy-baroud/" title="Posts by Dr Ramzy Baroud" rel="author">Dr Ramzy Baroud</a> | 28/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/remembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/TN-DV-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/TN-DV-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/remembering-t-nagi-reddy-his-college-days-in-bhu-and-mk-gandhi/">Remembering T.Nagi Reddy, his college days in BHU and MK Gandhi</a> <br /><small><a href="https://countercurrents.org/author/ma-krishna/" title="Posts by MA Krishna" rel="author">MA Krishna</a> | 28/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/the-global-ruling-class-is-frog-marching-us-towards-extinction/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/New-Mexico-FIre-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/New-Mexico-FIre-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/the-global-ruling-class-is-frog-marching-us-towards-extinction/">The Global Ruling Class Is Frog-Marching Us Towards Extinction</a> <br /><small><a href="https://countercurrents.org/author/chris-hedges/" title="Posts by Chris Hedges" rel="author">Chris Hedges</a> | 27/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/from-bill-gates-to-the-great-refusal-farmers-on-the-frontline/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/01/farmers-rally-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/01/farmers-rally-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/from-bill-gates-to-the-great-refusal-farmers-on-the-frontline/">From Bill Gates to the Great Refusal – Farmers on the Frontline  </a> <br /><small><a href="https://countercurrents.org/author/colin-todhunter/" title="Posts by Colin Todhunter" rel="author">Colin Todhunter</a> | 27/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/gotabaya-rajapaksa-expected-to-return-says-official/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/Gotabaya-Rajapaksa-1-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/Gotabaya-Rajapaksa-1-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/gotabaya-rajapaksa-expected-to-return-says-official/">Gotabaya Rajapaksa Expected To Return, Says Official</a> <br /><small><a href="https://countercurrents.org/author/countercurrents-org/" title="Posts by Countercurrents Collective" rel="author">Countercurrents Collective</a> | 27/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/australias-2-top-universities-anti-arab-anti-semitic-anti-jewish-anti-semitic/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/university-of-melbourne-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/university-of-melbourne-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/australias-2-top-universities-anti-arab-anti-semitic-anti-jewish-anti-semitic/">Australia&#8217;s 2 Top Universities Anti-Arab Anti-Semitic &#038; Anti-Jewish Anti-Semitic</a> <br /><small><a href="https://countercurrents.org/author/dr-gideon-polya/" title="Posts by Dr Gideon Polya" rel="author">Dr Gideon Polya</a> | 27/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/chaff-candidates-the-race-for-the-uk-tory-leadership/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/truss-sunak-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/truss-sunak-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/chaff-candidates-the-race-for-the-uk-tory-leadership/">Chaff Candidates: The Race for the UK Tory Leadership</a> <br /><small><a href="https://countercurrents.org/author/binoy-kampmark/" title="Posts by Dr Binoy Kampmark" rel="author">Dr Binoy Kampmark</a> | 27/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/the-us-boxes-itself-in-over-taiwan-and-ukraine/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/China-USA-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/China-USA-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/the-us-boxes-itself-in-over-taiwan-and-ukraine/">The US Boxes Itself in over Taiwan and Ukraine</a> <br /><small><a href="https://countercurrents.org/author/kim-petersen/" title="Posts by Kim Petersen" rel="author">Kim Petersen</a> | 27/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/ukraine-war-a-rock-and-a-hard-place/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2018/01/Stethoscope-doctor-75x50.png" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2018/01/Stethoscope-doctor-75x50.png" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/ukraine-war-a-rock-and-a-hard-place/">Ukraine War: A Rock and a Hard Place </a> <br /><small><a href="https://countercurrents.org/author/shantanu-dutta/" title="Posts by Shantanu Dutta" rel="author">Shantanu Dutta</a> | 27/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/the-agnipath-scheme-makes-sense-in-larger-context-of-the-bjps-neoliberal-hindutva/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/06/agnipath-agniveer-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/06/agnipath-agniveer-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/the-agnipath-scheme-makes-sense-in-larger-context-of-the-bjps-neoliberal-hindutva/">The Agnipath scheme makes sense in larger context of the BJP&#8217;s Neoliberal Hindutva</a> <br /><small><a href="https://countercurrents.org/author/himanshu-shukla/" title="Posts by Himanshu Shukla" rel="author">Himanshu Shukla</a> | 27/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/why-injustice-to-himanshu-kumar-will-be-exceptionally-harmful-for-democracy/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/himanshu-kumar-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/himanshu-kumar-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/why-injustice-to-himanshu-kumar-will-be-exceptionally-harmful-for-democracy/">Why Injustice to Himanshu Kumar Will be Exceptionally Harmful for Democracy</a> <br /><small><a href="https://countercurrents.org/author/bharat-dogra/" title="Posts by Bharat Dogra" rel="author">Bharat Dogra</a> | 27/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/the-enduring-tyranny-of-oil-war-inflation-geopolitical-rivalry-and-soaring-world-temperatures/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/03/Oil-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/03/Oil-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/the-enduring-tyranny-of-oil-war-inflation-geopolitical-rivalry-and-soaring-world-temperatures/">The Enduring Tyranny of Oil &#8211; War, Inflation, Geopolitical Rivalry, and Soaring World Temperatures</a> <br /><small><a href="https://countercurrents.org/author/michael-t-klare/" title="Posts by Michael T Klare" rel="author">Michael T Klare</a> | 26/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/letter-from-anti-vizhinjam-adani-port-struggle-front/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/vizhinjam-adani-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/vizhinjam-adani-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/letter-from-anti-vizhinjam-adani-port-struggle-front/">Letter from Anti Vizhinjam Adani Port struggle front</a> <br /><small><a href="https://countercurrents.org/author/anitha-s/" title="Posts by Anitha S" rel="author">Anitha S</a> | 26/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/greenland-towards-a-protective-future/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2016/11/greenland-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2016/11/greenland-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/greenland-towards-a-protective-future/">Greenland &#8211; Towards A Protective Future</a> <br /><small><a href="https://countercurrents.org/author/bharat-dogra/" title="Posts by Bharat Dogra" rel="author">Bharat Dogra</a> | 26/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/china-pledges-serious-consequences-for-u-s-if-pelosi-visits-taiwan/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2019/09/nansi-pelosi-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2019/09/nansi-pelosi-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/china-pledges-serious-consequences-for-u-s-if-pelosi-visits-taiwan/">China Pledges Serious Consequences For U.S. If Pelosi Visits Taiwan</a> <br /><small><a href="https://countercurrents.org/author/countercurrents-org/" title="Posts by Countercurrents Collective" rel="author">Countercurrents Collective</a> | 26/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/50th-death-anniversary-of-charu-mazumdar/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/charu-mazumdar-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/charu-mazumdar-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/50th-death-anniversary-of-charu-mazumdar/">50th Death Anniversary of Charu Mazumdar</a> <br /><small><a href="https://countercurrents.org/author/harsh-thakor/" title="Posts by Harsh Thakor" rel="author">Harsh Thakor</a> | 26/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/documenting-a-story-of-change/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/dharavi-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/dharavi-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/documenting-a-story-of-change/">Documenting a Story of Change</a> <br /><small><a href="https://countercurrents.org/author/mithila-naik-satam/" title="Posts by Mithila Naik-Satam" rel="author">Mithila Naik-Satam</a> | 26/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/sri-lankan-president-ranil-wickremasinghe-will-face-peoples-anger/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/Ranil-Wickremasinghe-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/Ranil-Wickremasinghe-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/sri-lankan-president-ranil-wickremasinghe-will-face-peoples-anger/">Sri Lankan President &#8211; Ranil Wickremasinghe will face people&#8217;s anger</a> <br /><small><a href="https://countercurrents.org/author/kumarathasan-rasingam/" title="Posts by Kumarathasan Rasingam" rel="author">Kumarathasan Rasingam</a> | 26/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/need-for-transparency-in-disclosing-fiscal-liabilities-under-the-frbm/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2020/05/nirmala-sitharaman-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2020/05/nirmala-sitharaman-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/need-for-transparency-in-disclosing-fiscal-liabilities-under-the-frbm/">Need for transparency in disclosing fiscal liabilities under the FRBM</a> <br /><small><a href="https://countercurrents.org/author/e-a-s-sarma/" title="Posts by E A S Sarma" rel="author">E A S Sarma</a> | 26/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/one-major-way-we-can-reduce-the-suffering-of-animals-raised-for-food/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2017/09/chicken-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2017/09/chicken-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/one-major-way-we-can-reduce-the-suffering-of-animals-raised-for-food/">One Major Way We Can Reduce the Suffering of Animals Raised for Food</a> <br /><small><a href="https://countercurrents.org/author/karen-davis/" title="Posts by Karen Davis" rel="author">Karen Davis</a> | 26/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/the-hundred-year-war-on-palestine/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/p-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/p-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/the-hundred-year-war-on-palestine/">The Hundred Year War on Palestine</a> <br /><small><a href="https://countercurrents.org/author/jim-miles/" title="Posts by Jim Miles" rel="author">Jim Miles</a> | 26/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/fascist-interrogation-of-revolutionary-intellectuals-in-the-name-of-curbing-maoists-in-andhra-pradesh/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/12/National-Investigation-Agency-NIA-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/12/National-Investigation-Agency-NIA-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/fascist-interrogation-of-revolutionary-intellectuals-in-the-name-of-curbing-maoists-in-andhra-pradesh/">Fascist interrogation of Revolutionary Intellectuals in the name of curbing ‘Maoists’ in Andhra Pradesh</a> <br /><small><a href="https://countercurrents.org/author/harsh-thakor/" title="Posts by Harsh Thakor" rel="author">Harsh Thakor</a> | 26/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/why-senior-veterans-of-armed-forces-are-worried-about-agnipath/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/06/agnipath-agniveer-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/06/agnipath-agniveer-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/why-senior-veterans-of-armed-forces-are-worried-about-agnipath/">Why Senior Veterans of Armed Forces Are Worried about Agnipath</a> <br /><small><a href="https://countercurrents.org/author/bharat-dogra/" title="Posts by Bharat Dogra" rel="author">Bharat Dogra</a> | 26/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/anti-war-and-human-rights-leader-ariel-gold-appointed-as-for-usa-executive-director-in-historic-hire/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/Ariel-Gold-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/Ariel-Gold-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/anti-war-and-human-rights-leader-ariel-gold-appointed-as-for-usa-executive-director-in-historic-hire/">Anti-War and Human Rights Leader Ariel Gold Appointed as FOR-USA Executive Director in Historic Hire</a> <br /><small><a href="https://countercurrents.org/author/press-release/" title="Posts by Press Release" rel="author">Press Release</a> | 26/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/paper-straws-are-not-enough/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/09/Green-Capitalism-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/09/Green-Capitalism-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/paper-straws-are-not-enough/">Paper Straws Are Not Enough</a> <br /><small><a href="https://countercurrents.org/author/robert-hunziker/" title="Posts by Robert Hunziker" rel="author">Robert Hunziker</a> | 25/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/an-asia-pacific-statement-of-faith-communities-on-israel-as-an-apartheid-state/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/08/israel-apartheid-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/08/israel-apartheid-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/an-asia-pacific-statement-of-faith-communities-on-israel-as-an-apartheid-state/">An Asia-Pacific Statement of Faith Communities on Israel as an Apartheid State</a> <br /><small><a href="https://countercurrents.org/author/press-release/" title="Posts by Press Release" rel="author">Press Release</a> | 25/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/the-cjis-complaint/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2019/11/supreme-court-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2019/11/supreme-court-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/the-cjis-complaint/">The CJI&#8217;s Complaint</a> <br /><small><a href="https://countercurrents.org/author/hiren-gohain/" title="Posts by Hiren Gohain" rel="author">Hiren Gohain</a> | 25/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/international-accountability-myanmar-the-icj-and-the-genocide-question/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2017/09/Rohingya-Muslim-Genocide-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2017/09/Rohingya-Muslim-Genocide-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/international-accountability-myanmar-the-icj-and-the-genocide-question/">International Accountability: Myanmar, the ICJ and the Genocide Question</a> <br /><small><a href="https://countercurrents.org/author/binoy-kampmark/" title="Posts by Dr Binoy Kampmark" rel="author">Dr Binoy Kampmark</a> | 25/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/temperature-in-greenland-causes-unusual-extensive-melting-of-ice-sheet-boosts-sea-level/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/greenland-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/greenland-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/temperature-in-greenland-causes-unusual-extensive-melting-of-ice-sheet-boosts-sea-level/">Temperature In Greenland Causes Unusual Extensive Melting Of Ice Sheet, Boosts Sea Level</a> <br /><small><a href="https://countercurrents.org/author/countercurrents-org/" title="Posts by Countercurrents Collective" rel="author">Countercurrents Collective</a> | 25/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/president-should-play-a-proactive-role-for-tribals/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/draupadi-murmu-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/draupadi-murmu-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/president-should-play-a-proactive-role-for-tribals/">President should play a proactive role for tribals</a> <br /><small><a href="https://countercurrents.org/author/e-a-s-sarma/" title="Posts by E A S Sarma" rel="author">E A S Sarma</a> | 25/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/how-the-policies-of-globalization-exploited-the-resources-and-economy-of-the-developing-countries/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2018/02/globalisation1-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2018/02/globalisation1-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/how-the-policies-of-globalization-exploited-the-resources-and-economy-of-the-developing-countries/">How the policies of globalization exploited the resources and economy of the developing countries</a> <br /><small><a href="https://countercurrents.org/author/tarun-kumar/" title="Posts by Tarun Kumar" rel="author">Tarun Kumar</a> | 25/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/cdc-prioritizes-a-healthy-public-or-a-healthy-economy/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/CDC-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/CDC-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/cdc-prioritizes-a-healthy-public-or-a-healthy-economy/">CDC Prioritizes a Healthy Public or a Healthy Economy?</a> <br /><small><a href="https://countercurrents.org/author/ellen-isaacs/" title="Posts by Ellen Isaacs" rel="author">Ellen Isaacs</a> | 25/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/chorus-of-choices-in-10-notes/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/earth-3-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/earth-3-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/chorus-of-choices-in-10-notes/">CHORUS of CHOICES &#8211; In 10 Notes</a> <br /><small><a href="https://countercurrents.org/author/david-sparenberg/" title="Posts by David Sparenberg" rel="author">David Sparenberg</a> | 25/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/welfare-programs-is-the-glass-half-full-or-half-empty/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/pradhan-Mantri-Matru-Vandana-Yojana-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/pradhan-Mantri-Matru-Vandana-Yojana-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/welfare-programs-is-the-glass-half-full-or-half-empty/">Welfare Programs—Is the Glass Half Full or Half Empty?</a> <br /><small><a href="https://countercurrents.org/author/bharat-dogra/" title="Posts by Bharat Dogra" rel="author">Bharat Dogra</a> | 25/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/will-social-media-unite-kashmir/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2018/07/social-media-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2018/07/social-media-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/will-social-media-unite-kashmir/">Will social media unite Kashmir?</a> <br /><small><a href="https://countercurrents.org/author/nayeema-ahmad-mahjoor/" title="Posts by Nayeema Ahmad Mahjoor" rel="author">Nayeema Ahmad Mahjoor</a> | 25/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/welcome-president-draupadi-murmu/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/Draupadi-Murmu-1-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/Draupadi-Murmu-1-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/welcome-president-draupadi-murmu/">Welcome President Draupadi Murmu</a> <br /><small><a href="https://countercurrents.org/author/vidya-bhushan-rawat/" title="Posts by Vidya Bhushan Rawat" rel="author">Vidya Bhushan Rawat</a> | 25/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/dehli-aanganwadi-workers-and-helpers-union-gherao-development-department-in-delhi-protesting-termination/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/anganwadi-workers-protest-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/anganwadi-workers-protest-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/dehli-aanganwadi-workers-and-helpers-union-gherao-development-department-in-delhi-protesting-termination/">Dehli Aanganwadi Workers and Helpers Union gherao Development Department in Delhi protesting termination</a> <br /><small><a href="https://countercurrents.org/author/harsh-thakor/" title="Posts by Harsh Thakor" rel="author">Harsh Thakor</a> | 24/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/book-review-peoples-tales-from-narmada-valley/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/narmada-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/narmada-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/book-review-peoples-tales-from-narmada-valley/">Book Review: People’s Tales From Narmada Valley</a> <br /><small><a href="https://countercurrents.org/author/t-vijayendra/" title="Posts by T Vijayendra" rel="author">T Vijayendra</a> | 24/07/2022 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2022/07/burning-questions-of-the-sri-lankan-peoples-movement-what-is-to-be-done/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/sri-lanka-2-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2022/07/sri-lanka-2-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2022/07/burning-questions-of-the-sri-lankan-peoples-movement-what-is-to-be-done/">Burning Questions of the Sri Lankan People’s Movement: What is to be Done?  </a> <br /><small><a href="https://countercurrents.org/author/dr-maya-john/" title="Posts by Dr Maya John" rel="author">Dr Maya John</a> | 24/07/2022 </small> <br/><div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div></div><div class="featured-category"><h3 class="green"><a href="https://countercurrents.org/editors-picks/">Editor’s Picks</a></h3><div class="left-col"> <a href="https://countercurrents.org/2021/12/toofan-aur-deeya-storm-and-lamp-why-countercurrents-should-not-get-extinguished/" title="‘Toofan Aur Deeya’ (Storm and Lamp) – Why Countercurrents should not get extinguished"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2019/12/p-s-sahni-300x200.jpg" alt="‘Toofan Aur Deeya’ (Storm and Lamp) – Why Countercurrents should not get extinguished" class="Thumbnail thumbnail featured-cat" width="300" height="200" title="‘Toofan Aur Deeya’ (Storm and Lamp) – Why Countercurrents should not get extinguished 3"></noscript><img src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%20200%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2019/12/p-s-sahni-300x200.jpg" alt="‘Toofan Aur Deeya’ (Storm and Lamp) – Why Countercurrents should not get extinguished" class="lazyload Thumbnail thumbnail featured-cat" width="300" height="200" title="‘Toofan Aur Deeya’ (Storm and Lamp) – Why Countercurrents should not get extinguished 3"></a><div class="clear"></div><div class="left-col-content"><h2><a href="https://countercurrents.org/2021/12/toofan-aur-deeya-storm-and-lamp-why-countercurrents-should-not-get-extinguished/" title="‘Toofan Aur Deeya’ (Storm and Lamp) – Why Countercurrents should not get extinguished">‘Toofan Aur Deeya’ (Storm and Lamp) – Why Countercurrents should not get extinguished</a></h2><div class="featured-meta"> <span>29/12/2021</span> <span class="separator">&mdash;</span> <span>P S Sahni</span></div><p>Share:Share on WhatsAppShare on FacebookShare on TwitterShare on TelegramShare on RedditShare on Email Binu Mathew, the editor of Countercurrents.org and the editorial team have been working selflessly with minimal funds and accepting no advertisements. Besides CC abhors foreign institutional funding, corporate funding or government aid. It has been in existence for about two decades and standing on the side of<a class="more-link" href="https://countercurrents.org/2021/12/toofan-aur-deeya-storm-and-lamp-why-countercurrents-should-not-get-extinguished/">[Read More&#8230;]</a></p></div></div><div class="right-col"><ul><li> <a href="https://countercurrents.org/2021/12/why-readers-should-support-countercurrents/" title="Why Readers Should Support Countercurrents"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/John-Scales-Avery-100x75.jpg" alt="Why Readers Should Support Countercurrents" class="Thumbnail thumbnail featured-cat-small" width="100" height="75" title="Why Readers Should Support Countercurrents 5"></noscript><img src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2075%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/John-Scales-Avery-100x75.jpg" alt="Why Readers Should Support Countercurrents" class="lazyload Thumbnail thumbnail featured-cat-small" width="100" height="75" title="Why Readers Should Support Countercurrents 5"></a><div class="right-col-content"><h4><a href="https://countercurrents.org/2021/12/why-readers-should-support-countercurrents/" title="Why Readers Should Support Countercurrents">Why Readers Should Support Countercurrents</a></h4><div class="featured-meta"> <span>13/12/2021</span> <span class="separator">&mdash;</span> <span>John Scales Avery</span></div></div><div style="clear:both;"></div></li><li> <a href="https://countercurrents.org/2021/12/why-countercurrents-should-be-sustained-ram-puniyani/" title="Why Countercurrents Should Be Sustained: Ram Puniyani"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/12/Ram-Puniyani-100x75.jpg" alt="Why Countercurrents Should Be Sustained: Ram Puniyani" class="Thumbnail thumbnail featured-cat-small" width="100" height="75" title="Why Countercurrents Should Be Sustained: Ram Puniyani 6"></noscript><img src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2075%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/12/Ram-Puniyani-100x75.jpg" alt="Why Countercurrents Should Be Sustained: Ram Puniyani" class="lazyload Thumbnail thumbnail featured-cat-small" width="100" height="75" title="Why Countercurrents Should Be Sustained: Ram Puniyani 6"></a><div class="right-col-content"><h4><a href="https://countercurrents.org/2021/12/why-countercurrents-should-be-sustained-ram-puniyani/" title="Why Countercurrents Should Be Sustained: Ram Puniyani">Why Countercurrents Should Be Sustained: Ram Puniyani</a></h4><div class="featured-meta"> <span>06/12/2021</span> <span class="separator">&mdash;</span> <span>Dr Ram Puniyani</span></div></div><div style="clear:both;"></div></li></ul></div><div class="clear"></div></div><div id="archives-2" class="widget widget_archive"><h3 class="title">Archives</h3><div class="widget-content"><ul><li><a href='https://countercurrents.org/2022/07/'>July 2022</a></li><li><a href='https://countercurrents.org/2022/06/'>June 2022</a></li><li><a href='https://countercurrents.org/2022/05/'>May 2022</a></li><li><a href='https://countercurrents.org/2022/04/'>April 2022</a></li><li><a href='https://countercurrents.org/2022/03/'>March 2022</a></li><li><a href='https://countercurrents.org/2022/02/'>February 2022</a></li><li><a href='https://countercurrents.org/2022/01/'>January 2022</a></li><li><a href='https://countercurrents.org/2021/12/'>December 2021</a></li><li><a href='https://countercurrents.org/2021/11/'>November 2021</a></li><li><a href='https://countercurrents.org/2021/10/'>October 2021</a></li><li><a href='https://countercurrents.org/2021/09/'>September 2021</a></li><li><a href='https://countercurrents.org/2021/08/'>August 2021</a></li><li><a href='https://countercurrents.org/2021/07/'>July 2021</a></li><li><a href='https://countercurrents.org/2021/06/'>June 2021</a></li><li><a href='https://countercurrents.org/2021/05/'>May 2021</a></li><li><a href='https://countercurrents.org/2021/04/'>April 2021</a></li><li><a href='https://countercurrents.org/2021/03/'>March 2021</a></li><li><a href='https://countercurrents.org/2021/02/'>February 2021</a></li><li><a href='https://countercurrents.org/2021/01/'>January 2021</a></li><li><a href='https://countercurrents.org/2020/12/'>December 2020</a></li><li><a href='https://countercurrents.org/2020/11/'>November 2020</a></li><li><a href='https://countercurrents.org/2020/10/'>October 2020</a></li><li><a href='https://countercurrents.org/2020/09/'>September 2020</a></li><li><a href='https://countercurrents.org/2020/08/'>August 2020</a></li><li><a href='https://countercurrents.org/2020/07/'>July 2020</a></li><li><a href='https://countercurrents.org/2020/06/'>June 2020</a></li><li><a href='https://countercurrents.org/2020/05/'>May 2020</a></li><li><a href='https://countercurrents.org/2020/04/'>April 2020</a></li><li><a href='https://countercurrents.org/2020/03/'>March 2020</a></li><li><a href='https://countercurrents.org/2020/02/'>February 2020</a></li><li><a href='https://countercurrents.org/2020/01/'>January 2020</a></li><li><a href='https://countercurrents.org/2019/12/'>December 2019</a></li><li><a href='https://countercurrents.org/2019/11/'>November 2019</a></li><li><a href='https://countercurrents.org/2019/10/'>October 2019</a></li><li><a href='https://countercurrents.org/2019/09/'>September 2019</a></li><li><a href='https://countercurrents.org/2019/08/'>August 2019</a></li><li><a href='https://countercurrents.org/2019/07/'>July 2019</a></li><li><a href='https://countercurrents.org/2019/06/'>June 2019</a></li><li><a href='https://countercurrents.org/2019/05/'>May 2019</a></li><li><a href='https://countercurrents.org/2019/04/'>April 2019</a></li><li><a href='https://countercurrents.org/2019/03/'>March 2019</a></li><li><a href='https://countercurrents.org/2019/02/'>February 2019</a></li><li><a href='https://countercurrents.org/2019/01/'>January 2019</a></li><li><a href='https://countercurrents.org/2018/12/'>December 2018</a></li><li><a href='https://countercurrents.org/2018/11/'>November 2018</a></li><li><a href='https://countercurrents.org/2018/10/'>October 2018</a></li><li><a href='https://countercurrents.org/2018/09/'>September 2018</a></li><li><a href='https://countercurrents.org/2018/08/'>August 2018</a></li><li><a href='https://countercurrents.org/2018/07/'>July 2018</a></li><li><a href='https://countercurrents.org/2018/06/'>June 2018</a></li><li><a href='https://countercurrents.org/2018/05/'>May 2018</a></li><li><a href='https://countercurrents.org/2018/04/'>April 2018</a></li><li><a href='https://countercurrents.org/2018/03/'>March 2018</a></li><li><a href='https://countercurrents.org/2018/02/'>February 2018</a></li><li><a href='https://countercurrents.org/2018/01/'>January 2018</a></li><li><a href='https://countercurrents.org/2017/12/'>December 2017</a></li><li><a href='https://countercurrents.org/2017/11/'>November 2017</a></li><li><a href='https://countercurrents.org/2017/10/'>October 2017</a></li><li><a href='https://countercurrents.org/2017/09/'>September 2017</a></li><li><a href='https://countercurrents.org/2017/08/'>August 2017</a></li><li><a href='https://countercurrents.org/2017/07/'>July 2017</a></li><li><a href='https://countercurrents.org/2017/06/'>June 2017</a></li><li><a href='https://countercurrents.org/2017/05/'>May 2017</a></li><li><a href='https://countercurrents.org/2017/04/'>April 2017</a></li><li><a href='https://countercurrents.org/2017/03/'>March 2017</a></li><li><a href='https://countercurrents.org/2017/02/'>February 2017</a></li><li><a href='https://countercurrents.org/2017/01/'>January 2017</a></li><li><a href='https://countercurrents.org/2016/12/'>December 2016</a></li><li><a href='https://countercurrents.org/2016/11/'>November 2016</a></li><li><a href='https://countercurrents.org/2016/10/'>October 2016</a></li><li><a href='https://countercurrents.org/2016/09/'>September 2016</a></li><li><a href='https://countercurrents.org/2016/08/'>August 2016</a></li><li><a href='https://countercurrents.org/2016/07/'>July 2016</a></li><li><a href='https://countercurrents.org/2016/06/'>June 2016</a></li><li><a href='https://countercurrents.org/2015/11/'>November 2015</a></li></ul><div class="clear"></div></div></div><div id="media_image-2" class="widget widget_media_image"><h3 class="title"><div class="empty"></div></h3><div class="widget-content"><a href="https://countercurrents.org/home.htm"><noscript><img width="300" height="98" src="https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn-300x98.jpg" class="image wp-image-2060  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn-300x98.jpg 300w, https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn-168x55.jpg 168w, https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn.jpg 327w" sizes="(max-width: 300px) 100vw, 300px" /></noscript><img width="300" height="98" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%2098%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn-300x98.jpg" class="lazyload image wp-image-2060  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" data-srcset="https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn-300x98.jpg 300w, https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn-168x55.jpg 168w, https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn.jpg 327w" data-sizes="(max-width: 300px) 100vw, 300px" /></a><div class="clear"></div></div></div><div id="tag_cloud-2" class="widget widget_tag_cloud"><h3 class="title">Tags</h3><div class="widget-content"><div class="tagcloud"><a href="https://countercurrents.org/tag/afghanistan/" class="tag-cloud-link tag-link-702 tag-link-position-1" style="font-size: 14.934579439252pt;" aria-label="Afghanistan (229 items)">Afghanistan</a> <a href="https://countercurrents.org/tag/american-imperialism/" class="tag-cloud-link tag-link-156 tag-link-position-2" style="font-size: 16.11214953271pt;" aria-label="American Imperialism (283 items)">American Imperialism</a> <a href="https://countercurrents.org/tag/bhima-koregaon/" class="tag-cloud-link tag-link-1688 tag-link-position-3" style="font-size: 11.271028037383pt;" aria-label="Bhima Koregaon (119 items)">Bhima Koregaon</a> <a href="https://countercurrents.org/tag/black-lives-matter/" class="tag-cloud-link tag-link-371 tag-link-position-4" style="font-size: 9.3084112149533pt;" aria-label="Black Lives Matter (85 items)">Black Lives Matter</a> <a href="https://countercurrents.org/tag/book-review/" class="tag-cloud-link tag-link-351 tag-link-position-5" style="font-size: 15.457943925234pt;" aria-label="Book Review (250 items)">Book Review</a> <a href="https://countercurrents.org/tag/capitalism/" class="tag-cloud-link tag-link-651 tag-link-position-6" style="font-size: 8.5233644859813pt;" aria-label="Capitalism (73 items)">Capitalism</a> <a href="https://countercurrents.org/tag/citizenship-amendment-act/" class="tag-cloud-link tag-link-1963 tag-link-position-7" style="font-size: 12.448598130841pt;" aria-label="Citizenship Amendment Act (148 items)">Citizenship Amendment Act</a> <a href="https://countercurrents.org/tag/climate-change/" class="tag-cloud-link tag-link-174 tag-link-position-8" style="font-size: 18.990654205607pt;" aria-label="Climate Change (469 items)">Climate Change</a> <a href="https://countercurrents.org/tag/coronavirus/" class="tag-cloud-link tag-link-2035 tag-link-position-9" style="font-size: 22pt;" aria-label="Coronavirus (787 items)">Coronavirus</a> <a href="https://countercurrents.org/tag/counter-solutions/" class="tag-cloud-link tag-link-185 tag-link-position-10" style="font-size: 12.971962616822pt;" aria-label="Counter Solutions (162 items)">Counter Solutions</a> <a href="https://countercurrents.org/tag/covid19/" class="tag-cloud-link tag-link-2152 tag-link-position-11" style="font-size: 18.990654205607pt;" aria-label="COVID19 (462 items)">COVID19</a> <a href="https://countercurrents.org/tag/covid-response-watch/" class="tag-cloud-link tag-link-50481 tag-link-position-12" style="font-size: 14.018691588785pt;" aria-label="COVID Response Watch (195 items)">COVID Response Watch</a> <a href="https://countercurrents.org/tag/covid-vaccine/" class="tag-cloud-link tag-link-2161 tag-link-position-13" style="font-size: 8.785046728972pt;" aria-label="COVID Vaccine (76 items)">COVID Vaccine</a> <a href="https://countercurrents.org/tag/crw-reportage/" class="tag-cloud-link tag-link-50527 tag-link-position-14" style="font-size: 11.140186915888pt;" aria-label="CRW Reportage (116 items)">CRW Reportage</a> <a href="https://countercurrents.org/tag/dakota-access-pipeline/" class="tag-cloud-link tag-link-656 tag-link-position-15" style="font-size: 9.0467289719626pt;" aria-label="Dakota Access Pipeline (81 items)">Dakota Access Pipeline</a> <a href="https://countercurrents.org/tag/demonetisation/" class="tag-cloud-link tag-link-925 tag-link-position-16" style="font-size: 11.532710280374pt;" aria-label="Demonetisation (125 items)">Demonetisation</a> <a href="https://countercurrents.org/tag/donald-trump/" class="tag-cloud-link tag-link-353 tag-link-position-17" style="font-size: 14.672897196262pt;" aria-label="Donald Trump (219 items)">Donald Trump</a> <a href="https://countercurrents.org/tag/education/" class="tag-cloud-link tag-link-331 tag-link-position-18" style="font-size: 13.757009345794pt;" aria-label="Education (184 items)">Education</a> <a href="https://countercurrents.org/tag/environment/" class="tag-cloud-link tag-link-175 tag-link-position-19" style="font-size: 12.841121495327pt;" aria-label="Environment (157 items)">Environment</a> <a href="https://countercurrents.org/tag/farmers-march/" class="tag-cloud-link tag-link-1771 tag-link-position-20" style="font-size: 16.373831775701pt;" aria-label="Farmers Agitation (293 items)">Farmers Agitation</a> <a href="https://countercurrents.org/tag/farmers-bills/" class="tag-cloud-link tag-link-49990 tag-link-position-21" style="font-size: 16.242990654206pt;" aria-label="Farm Reform Laws (287 items)">Farm Reform Laws</a> <a href="https://countercurrents.org/tag/film-review/" class="tag-cloud-link tag-link-240 tag-link-position-22" style="font-size: 12.317757009346pt;" aria-label="Film Review (143 items)">Film Review</a> <a href="https://countercurrents.org/tag/global-warming/" class="tag-cloud-link tag-link-193 tag-link-position-23" style="font-size: 18.205607476636pt;" aria-label="Global Warming (406 items)">Global Warming</a> <a href="https://countercurrents.org/tag/health/" class="tag-cloud-link tag-link-301 tag-link-position-24" style="font-size: 12.841121495327pt;" aria-label="Health (156 items)">Health</a> <a href="https://countercurrents.org/tag/hindutva/" class="tag-cloud-link tag-link-335 tag-link-position-25" style="font-size: 9.0467289719626pt;" aria-label="Hindutva (80 items)">Hindutva</a> <a href="https://countercurrents.org/tag/human-rights/" class="tag-cloud-link tag-link-152 tag-link-position-26" style="font-size: 12.317757009346pt;" aria-label="Human Rights (145 items)">Human Rights</a> <a href="https://countercurrents.org/tag/iran/" class="tag-cloud-link tag-link-233 tag-link-position-27" style="font-size: 8.785046728972pt;" aria-label="Iran (77 items)">Iran</a> <a href="https://countercurrents.org/tag/israel/" class="tag-cloud-link tag-link-218 tag-link-position-28" style="font-size: 14.018691588785pt;" aria-label="Israel (192 items)">Israel</a> <a href="https://countercurrents.org/tag/julian-assange/" class="tag-cloud-link tag-link-693 tag-link-position-29" style="font-size: 13.757009345794pt;" aria-label="Julian Assange (184 items)">Julian Assange</a> <a href="https://countercurrents.org/tag/kashmir/" class="tag-cloud-link tag-link-164 tag-link-position-30" style="font-size: 16.766355140187pt;" aria-label="Kashmir (314 items)">Kashmir</a> <a href="https://countercurrents.org/tag/life/" class="tag-cloud-link tag-link-45931 tag-link-position-31" style="font-size: 15.981308411215pt;" aria-label="Life (274 items)">Life</a> <a href="https://countercurrents.org/tag/nuclear-war/" class="tag-cloud-link tag-link-198 tag-link-position-32" style="font-size: 8.6542056074766pt;" aria-label="Nuclear War (74 items)">Nuclear War</a> <a href="https://countercurrents.org/tag/palestine/" class="tag-cloud-link tag-link-217 tag-link-position-33" style="font-size: 18.07476635514pt;" aria-label="Palestine (395 items)">Palestine</a> <a href="https://countercurrents.org/tag/patriarchy/" class="tag-cloud-link tag-link-161 tag-link-position-34" style="font-size: 8pt;" aria-label="Patriarchy (67 items)">Patriarchy</a> <a href="https://countercurrents.org/tag/poetry/" class="tag-cloud-link tag-link-228 tag-link-position-35" style="font-size: 17.943925233645pt;" aria-label="Poetry (389 items)">Poetry</a> <a href="https://countercurrents.org/tag/rss/" class="tag-cloud-link tag-link-186 tag-link-position-36" style="font-size: 8.2616822429907pt;" aria-label="RSS (69 items)">RSS</a> <a href="https://countercurrents.org/tag/sri-lanka/" class="tag-cloud-link tag-link-221 tag-link-position-37" style="font-size: 9.5700934579439pt;" aria-label="Sri Lanka (88 items)">Sri Lanka</a> <a href="https://countercurrents.org/tag/standing-rock-sioux-protest/" class="tag-cloud-link tag-link-655 tag-link-position-38" style="font-size: 9.0467289719626pt;" aria-label="Standing Rock Sioux Protest (81 items)">Standing Rock Sioux Protest</a> <a href="https://countercurrents.org/tag/syria/" class="tag-cloud-link tag-link-244 tag-link-position-39" style="font-size: 11.794392523364pt;" aria-label="Syria (132 items)">Syria</a> <a href="https://countercurrents.org/tag/the-commons/" class="tag-cloud-link tag-link-344 tag-link-position-40" style="font-size: 10.224299065421pt;" aria-label="The Commons (100 items)">The Commons</a> <a href="https://countercurrents.org/tag/ukraine/" class="tag-cloud-link tag-link-159 tag-link-position-41" style="font-size: 15.981308411215pt;" aria-label="Ukraine (275 items)">Ukraine</a> <a href="https://countercurrents.org/tag/us-election-2020/" class="tag-cloud-link tag-link-2043 tag-link-position-42" style="font-size: 9.5700934579439pt;" aria-label="US Election 2020 (89 items)">US Election 2020</a> <a href="https://countercurrents.org/tag/us-elections-2016/" class="tag-cloud-link tag-link-283 tag-link-position-43" style="font-size: 9.5700934579439pt;" aria-label="US Elections 2016 (89 items)">US Elections 2016</a> <a href="https://countercurrents.org/tag/venezuela/" class="tag-cloud-link tag-link-366 tag-link-position-44" style="font-size: 14.542056074766pt;" aria-label="Venezuela (211 items)">Venezuela</a> <a href="https://countercurrents.org/tag/yemen/" class="tag-cloud-link tag-link-489 tag-link-position-45" style="font-size: 9.3084112149533pt;" aria-label="Yemen (85 items)">Yemen</a></div><div class="clear"></div></div></div></div><div class="clear"></div><div id="footer"><div class="column"></div><div class="column"></div><div class="column"></div><div class="column last"></div><div class="clear"></div></div><div class="clear"></div></div></div><div id="copyright"><div class="inner-wrap"> Copyright &copy; 2022 &mdash; <a href="https://countercurrents.org/" class="on">Countercurrents</a>. All Rights Reserved. <span>optimized by <a href="https://anivar.net/" target="_blank" title="Anivar Aravind">Anivar</a></span></div></div>  <script>var hide_fttb = ''</script> <script type="text/javascript">if ((navigator.doNotTrack==="yes") || (navigator.msDoNotTrack=="1") || (navigator.doNotTrack=="1") || (document.cookie.indexOf("dont_track_me=1")!==-1) || (document.cookie.indexOf("civicAllowCookies=no")!==-1)) { 
aop_around(document.body, 'appendChild'); aop_around(document.body, 'insertBefore');  
 }</script>  <script>(function(a, b, c) {
        var d = a.history,
            e = document,
            f = navigator || {},
            g = localStorage,
            h = encodeURIComponent,
            i = d.pushState,
            k = function() {
                return Math.random().toString(36)
            },
            l = function() {
                return g.cid || (g.cid = k()), g.cid
            },
            m = function(r) {
                var s = [];
                for (var t in r)
                    r.hasOwnProperty(t) && void 0 !== r[t] && s.push(h(t) + "=" + h(r[t]));
                return s.join("&")
            },
            n = function(r, s, t, u, v, w, x) {
                var z = "https://www.google-analytics.com/collect",
                    A = m({
                        v: "1",
                        ds: "web",
                        aip: c.anonymizeIp ? 1 : void 0,
                        tid: b,
                        cid: l(),
                        t: r || "pageview",
                        sd: c.colorDepth && screen.colorDepth ? screen.colorDepth + "-bits" : void 0,
                        dr: e.referrer ||
                            void 0,
                        dt: e.title,
                        dl: e.location.origin + e.location.pathname + e.location.search,
                        ul: c.language ?
                            (f.language || "").toLowerCase() : void 0,
                        de: c.characterSet ? e.characterSet : void 0,
                        sr: c.screenSize ? (a.screen || {}).width + "x" + (a.screen || {}).height : void 0,
                        vp: c.screenSize &&
                            a.visualViewport ? (a.visualViewport || {}).width + "x" + (a.visualViewport || {}).height : void 0,
                        ec: s || void 0,
                        ea: t || void 0,
                        el: u || void 0,
                        ev: v || void 0,
                        exd: w || void 0,
                        exf: "undefined" != typeof x &&
                            !1 == !!x ? 0 : void 0
                    });
                if (f.sendBeacon) f.sendBeacon(z, A);
                else {
                    var y = new XMLHttpRequest;
                    y.open("POST", z, !0), y.send(A)
                }
            };
        d.pushState = function(r) {
                return "function" == typeof d.onpushstate &&
                    d.onpushstate({
                        state: r
                    }), setTimeout(n, c.delay || 10), i.apply(d, arguments)
            }, n(),
            a.ma = {
                trackEvent: function o(r, s, t, u) {
                    return n("event", r, s, t, u)
                },
                trackException: function q(r, s) {
                    return n("exception", null, null, null, null, r, s)
                }
            }
    })
    (window, "UA-166669197-1", {
        anonymizeIp: true,
        siteSpeedSampleRate: 1,
        colorDepth: true,
        characterSet: true,
        screenSize: true,
        language: true
    })</script><noscript><style>.lazyload{display:none;}</style></noscript><script data-noptimize="1">window.lazySizesConfig=window.lazySizesConfig||{};window.lazySizesConfig.loadMode=1;</script><script async data-noptimize="1" src='https://cdn.countercurrents.org/wp-content/plugins/autoptimize/classes/external/js/lazysizes.min.js'></script> <script defer type='text/javascript' src='https://cdn.countercurrents.org/wp-content/plugins/float-to-top-button/js/jquery.scrollUp.min.js' id='fttb-script-js'></script> <script type='text/javascript' id='fttb-active-js-extra'>var fttb = {"topdistance":"300","topspeed":"300","animation":"fade","animationinspeed":"200","animationoutspeed":"200","scrolltext":"","imgurl":"https:\/\/countercurrents.org\/wp-content\/plugins\/float-to-top-button\/images\/","arrow_img":"arrow014.png","arrow_img_url":"","position":"lowerright","spacing_horizontal":"40px","spacing_vertical":"40px","opacity_out":"75","opacity_over":"99","zindex":"2147483647"};</script> <script defer type='text/javascript' src='https://cdn.countercurrents.org/wp-content/plugins/float-to-top-button/js/float-to-top-button.min.js' id='fttb-active-js'></script> <script type='text/javascript' id='hollerbox-popups-js-before'>HollerBox = {"active":[],"home_url":"https:\/\/countercurrents.org","is_preview":false,"is_frontend":true,"is_builder_preview":false,"routes":{"root":"https:\/\/countercurrents.org\/wp-json\/hollerbox","conversion":"https:\/\/countercurrents.org\/wp-json\/hollerbox\/conversion","impression":"https:\/\/countercurrents.org\/wp-json\/hollerbox\/impression","submit":"https:\/\/countercurrents.org\/wp-json\/hollerbox\/submit"},"nonces":{"_wprest":"4e66b35b63"},"settings":{"credit_disabled":true,"gdpr_enabled":false,"gdpr_text":"","cookie_compliance":false,"cookie_name":"viewed_cookie_policy","cookie_value":"yes","script_debug_mode":false}}</script> <script defer type='text/javascript' src='https://cdn.countercurrents.org/wp-content/plugins/holler-box/assets/js/popups.min.js' id='hollerbox-popups-js'></script> <script defer type='text/javascript' src='https://cdn.countercurrents.org/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script> <script defer type='text/javascript' src='https://cdn.countercurrents.org/wp-content/cache/autoptimize/js/autoptimize_single_850417bf7853c0623933a47243cb3a5a.js' id='flexslider-js'></script> <script defer type='text/javascript' src='https://cdn.countercurrents.org/wp-content/cache/autoptimize/js/autoptimize_single_990a226e7e90bdf1c1f675d245491eb5.js' id='caroufredsel-js'></script> <script defer type='text/javascript' src='https://cdn.countercurrents.org/wp-content/themes/alpha/js/fitvids.min.js' id='fitvids-js'></script> <script defer type='text/javascript' src='https://cdn.countercurrents.org/wp-content/cache/autoptimize/js/autoptimize_single_163e3f4ae2927872d8955dcae8b4bdce.js' id='dropdown-js'></script> <script defer type='text/javascript' src='https://cdn.countercurrents.org/wp-content/cache/autoptimize/js/autoptimize_single_bbd8ca801c00a12441120a7f6c9d530c.js' id='tabs-js'></script> <script defer type='text/javascript' src='https://cdn.countercurrents.org/wp-content/themes/alpha/js/jquery.placeholder.min.js' id='placeholder-js'></script> <script defer type='text/javascript' src='https://cdn.countercurrents.org/wp-content/cache/autoptimize/js/autoptimize_single_9ec53e74d4953e4a448a68e3b088799b.js' id='alpha-script-js'></script> <script defer type='text/javascript' src='https://cdn.countercurrents.org/wp-content/cache/autoptimize/js/autoptimize_single_91d3419c22ca3aaf16e35a34f620b967.js' id='akismet-frontend-js'></script> <script type="text/javascript" id="flying-scripts">const loadScriptsTimer=setTimeout(loadScripts,6*1000);const userInteractionEvents=["mouseover","keydown","touchstart","touchmove","wheel"];userInteractionEvents.forEach(function(event){window.addEventListener(event,triggerScriptLoader,{passive:!0})});function triggerScriptLoader(){loadScripts();clearTimeout(loadScriptsTimer);userInteractionEvents.forEach(function(event){window.removeEventListener(event,triggerScriptLoader,{passive:!0})})}
function loadScripts(){document.querySelectorAll("script[data-type='lazy']").forEach(function(elem){elem.setAttribute("src",elem.getAttribute("data-src"))})}</script> </body></html>