<!DOCTYPE html><html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://countercurrents.org/xmlrpc.php" /><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><link media="all" href="https://cdn.countercurrents.org/wp-content/cache/autoptimize/css/autoptimize_eea78a673c526a3a162924a393e9222f.css" rel="stylesheet" /><link media="screen" href="https://cdn.countercurrents.org/wp-content/cache/autoptimize/css/autoptimize_d97c3d0f130d41276b3bff577645c2c0.css" rel="stylesheet" /><title>Modest results of the meeting in Geneva | Countercurrents</title><link rel="canonical" href="https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Modest results of the meeting in Geneva | Countercurrents" /><meta property="og:description" content="Presidents Joseph Biden and Vladimir Putin met in Geneva on Wednesday, June 16. Both separately noted that the talks went well. “There’s been no hostility,” Putin said. “On the contrary, our meeting took place in a constructive spirit.” Biden meanwhile declared “the tone of the entire meeting… was good. Positive.” The spirit may have been constructive and the tone positive,[Read More...]" /><meta property="og:url" content="https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/" /><meta property="og:site_name" content="Countercurrents" /><meta property="article:publisher" content="https://facebook.com/countercurrents" /><meta property="article:published_time" content="2021-06-19T12:11:52+00:00" /><meta property="og:image" content="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Putin-Biden.jpg" /><meta property="og:image:width" content="700" /><meta property="og:image:height" content="389" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@Countercurrents" /><meta name="twitter:site" content="@Countercurrents" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Slavisha Batko Milacic" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="5 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://countercurrents.org/#organization","name":"Countercurrents.org","url":"https://countercurrents.org/","sameAs":["https://facebook.com/countercurrents","https://www.youtube.com/user/CCMEDIACHANNEL","https://en.wikipedia.org/wiki/Countercurrents.org","https://twitter.com/Countercurrents"],"logo":{"@type":"ImageObject","@id":"https://countercurrents.org/#logo","inLanguage":"en-US","url":"https://cdn.countercurrents.org/wp-content/uploads/2020/05/CC-Logo.jpg","contentUrl":"https://cdn.countercurrents.org/wp-content/uploads/2020/05/CC-Logo.jpg","width":840,"height":86,"caption":"Countercurrents.org"},"image":{"@id":"https://countercurrents.org/#logo"}},{"@type":"WebSite","@id":"https://countercurrents.org/#website","url":"https://countercurrents.org/","name":"Countercurrents","description":"Educate | Organize | Agitate","publisher":{"@id":"https://countercurrents.org/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://countercurrents.org/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/#primaryimage","inLanguage":"en-US","url":"https://cdn.countercurrents.org/wp-content/uploads/2021/06/Putin-Biden.jpg","contentUrl":"https://cdn.countercurrents.org/wp-content/uploads/2021/06/Putin-Biden.jpg","width":700,"height":389},{"@type":"WebPage","@id":"https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/#webpage","url":"https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/","name":"Modest results of the meeting in Geneva | Countercurrents","isPartOf":{"@id":"https://countercurrents.org/#website"},"primaryImageOfPage":{"@id":"https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/#primaryimage"},"datePublished":"2021-06-19T12:11:52+00:00","dateModified":"2021-06-19T12:11:52+00:00","breadcrumb":{"@id":"https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/"]}]},{"@type":"BreadcrumbList","@id":"https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://countercurrents.org/"},{"@type":"ListItem","position":2,"name":"World","item":"https://countercurrents.org/world/"},{"@type":"ListItem","position":3,"name":"Modest results of the meeting in Geneva"}]},{"@type":["Article","NewsArticle"],"@id":"https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/#article","isPartOf":{"@id":"https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/#webpage"},"author":{"@id":"https://countercurrents.org/#/schema/person/3d01b722b639601da24901e44a0fe6a4"},"headline":"Modest results of the meeting in Geneva","datePublished":"2021-06-19T12:11:52+00:00","dateModified":"2021-06-19T12:11:52+00:00","mainEntityOfPage":{"@id":"https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/#webpage"},"wordCount":1077,"commentCount":0,"publisher":{"@id":"https://countercurrents.org/#organization"},"image":{"@id":"https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/#primaryimage"},"thumbnailUrl":"https://cdn.countercurrents.org/wp-content/uploads/2021/06/Putin-Biden.jpg","keywords":["Russia-US Relations"],"articleSection":["World"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/#respond"]}],"copyrightYear":"2021","copyrightHolder":{"@id":"https://countercurrents.org/#organization"}},{"@type":"Person","@id":"https://countercurrents.org/#/schema/person/3d01b722b639601da24901e44a0fe6a4","name":"Slavisha Batko Milacic","image":{"@type":"ImageObject","@id":"https://countercurrents.org/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/8d2a2877c25211c2f19adbaf55f99f22?s=96&r=g","contentUrl":"https://secure.gravatar.com/avatar/8d2a2877c25211c2f19adbaf55f99f22?s=96&r=g","caption":"Slavisha Batko Milacic"},"url":"https://countercurrents.org/author/slavisha-batko-milacic/"}]}</script> <link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//use.fontawesome.com' /><link rel='dns-prefetch' href='//s.w.org' /><link href='https://use.fontawesome.com' rel='preconnect' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link href='https://www.googletagmanager.com' rel='preconnect' /><link href='https://cse.google.com' rel='preconnect' /><link href='https://translate.googleapis.com' rel='preconnect' /><link href='https://www.google-analytics.com' rel='preconnect' /><link href='https://www.google.com' rel='preconnect' /><link href='https://c.disquscdn.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Countercurrents &raquo; Feed" href="https://countercurrents.org/feed/" /><link rel="alternate" type="application/rss+xml" title="Countercurrents &raquo; Comments Feed" href="https://countercurrents.org/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Countercurrents &raquo; Modest results of the meeting in Geneva Comments Feed" href="https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cdn.countercurrents.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='font-awesome-css'  href='https://use.fontawesome.com/releases/v5.10.2/css/all.css' type='text/css' media='all' /><link rel='stylesheet' id='dashicons-css'  href='https://cdn.countercurrents.org/wp-includes/css/dashicons.min.css' type='text/css' media='all' /><link rel='stylesheet' id='google-fonts-css'  href='https://cdn.countercurrents.org/wp-content/cache/autoptimize/css/autoptimize_single_3efe94d1c5a50baa9efb34bab61e3490.css' type='text/css' media='all' /> <script type="text/javascript">var dnt_config={ifdnt:"1",mode:"blacklist",black:["media6degrees.com","quantserve.com","lockerz.com"],white:[]};</script><script type='text/javascript' src='https://cdn.countercurrents.org/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-166669197-1' id='google_gtagjs-js' async></script> <script type='text/javascript' id='google_gtagjs-js-after'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["countercurrents.org"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-166669197-1", {"anonymize_ip":true});</script> <link rel="https://api.w.org/" href="https://countercurrents.org/wp-json/" /><link rel="alternate" type="application/json" href="https://countercurrents.org/wp-json/wp/v2/posts/68466" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://countercurrents.org/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://countercurrents.org/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.7.2" /><link rel='shortlink' href='https://countercurrents.org/?p=68466' /><link rel="alternate" type="application/json+oembed" href="https://countercurrents.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcountercurrents.org%2F2021%2F06%2Fmodest-results-of-the-meeting-in-geneva%2F" /><link rel="alternate" type="text/xml+oembed" href="https://countercurrents.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcountercurrents.org%2F2021%2F06%2Fmodest-results-of-the-meeting-in-geneva%2F&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.34.1" /><meta name="generator" content="Alpha Child 1.0" /><meta name="generator" content="WPZOOM Framework 1.9.9" /> <script type="text/javascript">document.write('<style type="text/css">.tabber{display:none;}</style>');</script> <link rel="icon" href="https://cdn.countercurrents.org/wp-content/uploads/2020/05/twitternew_400x400-55x55.jpg" sizes="32x32" /><link rel="icon" href="https://cdn.countercurrents.org/wp-content/uploads/2020/05/twitternew_400x400-300x300.jpg" sizes="192x192" /><link rel="apple-touch-icon" href="https://cdn.countercurrents.org/wp-content/uploads/2020/05/twitternew_400x400-300x300.jpg" /><meta name="msapplication-TileImage" content="https://cdn.countercurrents.org/wp-content/uploads/2020/05/twitternew_400x400-300x300.jpg" /></head><body class="post-template-default single single-post postid-68466 single-format-standard custom-background"><header id="header"><div id="menutop"><div class="inner-wrap"> <a class="btn_menu" id="toggle-top" href="#"></a><div id="topmenu-wrap"><ul id="topmenu" class="dropdown"><li id="menu-item-2003" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2003"><a href="https://countercurrents.org/fair-use-notice/">Fair Use</a></li><li id="menu-item-2004" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2004"><a href="https://countercurrents.org/disclaimer/">Disclaimer</a></li><li id="menu-item-50797" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-50797"><a href="https://countercurrents.org/privacy-policy/">Privacy Policy</a></li><li id="menu-item-2006" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2006"><a href="https://countercurrents.org/contact/">Contact</a></li><li id="menu-item-2096" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2096"><a href="https://countercurrents.org/subscription/">Subscription</a></li><li id="menu-item-2095" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2095"><a href="https://countercurrents.org/news-letter/">News Letter</a></li><li id="menu-item-2005" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2005"><a href="https://countercurrents.org/countercurrents-submission-policy/">Submission Policy</a></li><li id="menu-item-2007" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2007"><a href="https://countercurrents.org/about/">About</a></li></ul></div><div id="navsocial"><div id="lsi_widget-2" class="widget widget_lsi_widget"><h3 class="title">Social Icons</h3><ul class="lsi-social-icons icon-set-lsi_widget-2" style="text-align: left"><li class="lsi-social-facebook"><a class="" rel="nofollow noopener noreferrer" title="Facebook" aria-label="Facebook" href="https://www.facebook.com/countercurrents/" target="_blank"><i class="lsicon lsicon-facebook"></i></a></li><li class="lsi-social-twitter"><a class="" rel="nofollow noopener noreferrer" title="Twitter" aria-label="Twitter" href="https://twitter.com/countercurrents" target="_blank"><i class="lsicon lsicon-twitter"></i></a></li><li class="lsi-social-youtube"><a class="" rel="nofollow noopener noreferrer" title="YouTube" aria-label="YouTube" href="https://www.youtube.com/user/CCMEDIACHANNEL" target="_blank"><i class="lsicon lsicon-youtube"></i></a></li><li class="lsi-social-rss"><a class="" rel="nofollow noopener noreferrer" title="RSS" aria-label="RSS" href="https://countercurrents.org/feed/" target="_blank"><i class="lsicon lsicon-rss"></i></a></li></ul><div class="clear"></div></div></div><div class="clear"></div></div></div><div id="header-widget-area" class="chw-widget-area widget-area" role="complementary"><div class="widget_text chw-widget"><h2 class="chw-title"><div class="empty"></div></h2><div class="textwidget custom-html-widget"> <a style="background: #9a6400;" href="https://countercurrents.org/covidresponsewatch/"> <noscript><img class="center" src="https://cdn.countercurrents.org/wp-content/uploads/2016/06/COVID-Banner.jpg" alt="COVID Response Watch"></noscript><img class="lazyload center" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20210%20140%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2016/06/COVID-Banner.jpg" alt="COVID Response Watch"></a></div></div></div><div class="inner-wrap header-wrap"><div id="logo"> <a href="https://countercurrents.org" title="Educate | Organize | Agitate"> <noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2016/06/logo-1-4.png" alt="Countercurrents" /></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20210%20140%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2016/06/logo-1-4.png" alt="Countercurrents" /> </a></div><div class="clear"></div><div id="menu"> <a class="btn_menu" id="toggle-main" href="#"></a><div id="menu-wrap"><ul id="mainmenu" class="dropdown"><li id="menu-item-66581" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66581"><a href="https://countercurrents.org/india/">India</a></li><li id="menu-item-66580" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-66580"><a href="https://countercurrents.org/world/">World</a></li><li id="menu-item-66619" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66619"><a href="https://countercurrents.org/covidresponsewatch/">COVID Response Watch</a></li><li id="menu-item-66583" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66583"><a href="https://countercurrents.org/human-rights/">Human Rights</a></li><li id="menu-item-66584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66584"><a href="https://countercurrents.org/arts-literature/">Arts/Literature</a></li><li id="menu-item-66585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66585"><a href="https://countercurrents.org/imperialism/">Imperialism</a></li><li id="menu-item-66586" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66586"><a href="https://countercurrents.org/climate-change/">Climate Change</a></li><li id="menu-item-66711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66711"><a href="https://countercurrents.org/palestine/">Palestine</a></li></ul></div><div class="clear"></div></div></div></header><div class="container"><div class="content-wrap"><div class="single-area"><div class="post-meta"><h1 class="title"> <a href="https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/" title="Permalink to Modest results of the meeting in Geneva" rel="bookmark">Modest results of the meeting in Geneva</a></h1> in <a href="https://countercurrents.org/world/" rel="category tag">World</a> <span class="separator">&mdash;</span> by <a href="https://countercurrents.org/author/slavisha-batko-milacic/" title="Posts by Slavisha Batko Milacic" rel="author">Slavisha Batko Milacic</a> <span class="separator">&mdash;</span> 19/06/2021</div><div id="post-68466" class="clearfix post-wrap post-68466 post type-post status-publish format-standard has-post-thumbnail hentry category-world tag-russia-us-relations"><div class="entry"><div class="scriptlesssocialsharing"><h3 class="scriptlesssocialsharing__heading">Share:</h3><div class="scriptlesssocialsharing__buttons"><a class="button whatsapp" target="_blank" href="https://api.whatsapp.com/send?text=Modest%20results%20of%20the%20meeting%20in%20Geneva%20%E2%80%94%20https%3A%2F%2Fcountercurrents.org%2F2021%2F06%2Fmodest-results-of-the-meeting-in-geneva%2F" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>WhatsApp</span></a><a class="button facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fcountercurrents.org%2F2021%2F06%2Fmodest-results-of-the-meeting-in-geneva%2F" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Facebook</span></a><a class="button twitter" target="_blank" href="https://twitter.com/intent/tweet?text=Modest%20results%20of%20the%20meeting%20in%20Geneva&#038;url=https%3A%2F%2Fcountercurrents.org%2F2021%2F06%2Fmodest-results-of-the-meeting-in-geneva%2F&#038;via=countercurrents&#038;related=countercurrents" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Twitter</span></a><a class="button telegram" target="_blank" href="https://telegram.me/share/url?url=https%3A%2F%2Fcountercurrents.org%2F2021%2F06%2Fmodest-results-of-the-meeting-in-geneva%2F&#038;text=Modest%20results%20of%20the%20meeting%20in%20Geneva" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Telegram</span></a><a class="button reddit" target="_blank" href="https://www.reddit.com/submit?url=https%3A%2F%2Fcountercurrents.org%2F2021%2F06%2Fmodest-results-of-the-meeting-in-geneva%2F" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Reddit</span></a><a class="button email" href="mailto:?body=I%20read%20this%20post%20and%20wanted%20to%20share%20it%20with%20you.%20Here%27s%20the%20link%3A%20https%3A%2F%2Fcountercurrents.org%2F2021%2F06%2Fmodest-results-of-the-meeting-in-geneva%2F&#038;subject=A%20post%20worth%20sharing%3A%20Modest%20results%20of%20the%20meeting%20in%20Geneva" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Email</span></a></div></div><p style="text-align: center;"><noscript><img class="aligncenter size-full wp-image-68467" src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Putin-Biden.jpg" alt="" width="700" height="389" srcset="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Putin-Biden.jpg 700w, https://cdn.countercurrents.org/wp-content/uploads/2021/06/Putin-Biden-300x167.jpg 300w" sizes="(max-width: 700px) 100vw, 700px" /></noscript><img class="lazyload aligncenter size-full wp-image-68467" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20700%20389%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Putin-Biden.jpg" alt="" width="700" height="389" data-srcset="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Putin-Biden.jpg 700w, https://cdn.countercurrents.org/wp-content/uploads/2021/06/Putin-Biden-300x167.jpg 300w" data-sizes="(max-width: 700px) 100vw, 700px" /></p><p>Presidents Joseph Biden and Vladimir Putin met in Geneva on Wednesday, June 16. Both separately noted that the talks went well. “There’s been no hostility,” Putin said. “On the contrary, our meeting took place in a constructive spirit.” Biden meanwhile declared “the tone of the entire meeting… was good. Positive.”</p><p>The spirit may have been constructive and the tone positive, but no major step forward was made to reset the chronically strained relations between Moscow and Washington. Although the meeting went as well as could be expected, major differences remain on a range of issues, including cyberattacks and human rights.</p><p>Putin rejected accusations Russia was involved in cyberattacks against U.S. institutions and declared that the U.S. government was the main offender in this area. On human rights he said that the U.S. supports opposition groups in Russia in order to weaken it, since Washington openly sees Russia as an adversary. Putin reiterated that Moscow did not see domestic politics as up for negotiation or discussion. He also said that pro-Trump demonstrators who stormed the Capitol on Jan. 6 were merely expressing reasonable political demands, for which they now faced punitive jail terms.</p><p>For his part Biden ensured the summit would be seen as the opposite of Donald Trump’s notably cordial meeting with Putin in Helsinki three years ago. He said that he had pressed the Russian leader on a range of issues, such as human rights, and that he would continue doing so. “No President of the United States could keep faith with the American people if they did not speak out to defend our democratic values, to stand up for the universal rights and fundamental freedoms that all men and women have, in our view,” Biden said he told Putin. “That’s just part of the DNA of our country… It’s about who we are.”</p><p>On the modest plus side the two leaders agreed that their ambassadors, who were recalled amid the rising tensions, should return to their posts in the near future. In addition, the U.S. and Russia would start “consultations” on cyber-related issues. As for the overall tone of the meeting, the Russian president paraphrased Leo Tolstoy by saying “there is no happiness in life only glimmers of it. Cherish them.”</p><p>“I think that in this situation, there can’t be any kind of family trust,” Putin concluded. “But I think we’ve seen some glimmers.”</p><p>Media commentary around the world reflected one common theme: at least it is reassuring that there is a dialogue. “The US-Russian summit in Geneva confirmed the low expectations for the meeting,” commented the Neue Zürcher Zeitung, Switzerland’s leading daily:</p><p>There were hardly any concrete agreements, but at least the American president is no longer inviting attack from his Russian counterpart. The chorus of commentators was pretty unanimous in the run-up to the summit from Moscow to Washington: There was no significant room for concessions or a change of strategy, either on the American or on the Russian side. The expectations therefore had to be set extremely low.</p><p>These low expectations were noted by the Frankfurter Allgemeine Zeitung as well, which found it encouraging that the meeting lasted considerably longer than expected. The paper also thought it a hopeful sign that “the Russian President, who had already made the Pope and the British [sic!] Queen wait, arrived on time.”</p><p>“The summit flowed along conventional diplomatic lines:” wrote The Guardian; “a handshake, several hours of intensive talks and separate press conferences afterwards. The ghost of Helsinki was exorcised.” According to the British daily, the obvious and easy “deliverables” were achieved:</p><p>“One was to normalise the situation of Russia and America’s ambassadors…</p><p>“There will also be consultations between the US state department and the Russian foreign ministry on a range of issues including the Start III nuclear treaty, due to expire in 2024, and cybersecurity.”</p><p>The Russian media, unlike their Western counterparts, emphasize that one area of agreement in Geneva concerned the implementation of the Minsk agreements. The daily Rossiyskaya Gazeta noted Putin’s statement that Biden agreed with him that the Minsk agreements should be at the heart of the settlement in Ukraine. Quoting Peter Kuznick, professor of history at American University, the paper notes the summit was an important step in the right direction for both sides. No one expected a breakthrough, he said, but the two leaders respectfully and clearly indicated their interest in finding possible areas of common interest:</p><p>Both presidents understood each other’s ‘red lines’ and marked them more clearly. Their summaries after the meeting did not contradict, but rather emphasized and complemented each other. It seems to me that Putin was speaking to the whole world, while Biden spoke more to an audience within America, with an emphasis on human rights.</p><p>Considering the current state of bilateral relations, the Geneva summit is the maximum that could be expected. All that was deemed possible, but not obligatory, did happen, Professor Fyodor Lukyanov of Moscow’s School of Economics noted.</p><p>The conversation was businesslike and informative. This means that from the insane phase we’ve had in recent years, with normal relationship replaced by sheer hysteria, we are moving into a phase of more structured rivalry… The summit only outlined a way out of the impasse. Now we have to do all the work that is normally done before the summit. Since it was not done this time, solid steps will be prepared for some future milestone.</p><p>Prior to this meeting, Washington strengthened Russophobic sentiments in countries that follow American foreign policy. The peak of Russophobia was represented by the events in the Czech Republic, Bulgaria, but also by a number of other states which adjust it`s foreign policy to Washington’s foreign policy. Bearing in mind that at the moment relations between Washington and Moscow are not friendly, under American command, that kind of states accuse Russia constantly, including for events that happened years ago.</p><p>More in the documentary:</p><p><iframe title="Байдън. Миналото като прогноза за бъдещето" width="690" height="388" src="https://www.youtube.com/embed/Aw4myXWhiHg?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p><p><strong>Slavisha Batko Milacic</strong> &#8211; I live in Podgorica (capital of Montenegro), I am 30 years old, and I graduated history at University of Montenegro. My specialist graduate thesis was: &#8220;Foreign Policy of Russia from 1905 to 1917&#8221;. I have been doing analytics for years, writing in English and Serbian about the situation in the Balkans and Europe.</p><hr /><p><a href="https://countercurrents.org/news-letter" data-wpel-link="internal">GET COUNTERCURRENTS DAILY NEWSLETTER STRAIGHT TO YOUR INBOX</a></p><hr /><p>&nbsp;</p><div class="relpost-thumb-wrapper"><div class="relpost-thumb-container"><h3>Related posts:</h3><div style="clear: both"></div><div style="clear: both"></div><div class="relpost-block-container"><a class="relpost-block-single" href="https://countercurrents.org/2021/06/geneva-summit-leading-from-the-front-while-dealing-with-media/"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt="Geneva Summit: Leading from the front while dealing with media"  style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2021/06/Putin-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;">Geneva Summit: Leading from the front while dealing with media</div></div></a><a class="relpost-block-single" href="https://countercurrents.org/2021/06/takeaways-from-biden-putin-summit/"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt="Takeaways from Biden-Putin summit"  style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2021/06/Biden-Putin-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;">Takeaways from Biden-Putin summit</div></div></a><a class="relpost-block-single" href="https://countercurrents.org/2021/06/contradictions-in-the-anachronistic-us-russian-relationship/"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt="Contradictions in the Anachronistic US-Russian Relationship"  style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2021/06/Biden-Putin-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;">Contradictions in the Anachronistic US-Russian Relationship</div></div></a><a class="relpost-block-single" href="https://countercurrents.org/2021/06/biden-clears-the-air-on-ties-with-russia-and-china/"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt="Biden clears the air on ties with Russia and China"  style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2021/06/Biden-US-Russia-China-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;">Biden clears the air on ties with Russia and China</div></div></a><a class="relpost-block-single" href="https://countercurrents.org/2021/06/talking-or-bickering-will-putin-and-biden-discuss-the-dirty-war-in-the-middle-east/"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt="Talking or bickering? Will Putin and Biden discuss the “dirty war” in the Middle East?"  style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2016/06/russia-usa-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;">Talking or bickering? Will Putin and Biden discuss the “dirty war” in the Middle East?</div></div></a><a class="relpost-block-single" href="https://countercurrents.org/2021/06/biden-wants-to-remain-engaged-with-russia-china/"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt="Biden wants to remain engaged with Russia, China"  style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2021/06/Liu-He-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;">Biden wants to remain engaged with Russia, China</div></div></a><a class="relpost-block-single" href="https://countercurrents.org/2021/04/the-ukrainian-crisis-and-bidens-interests/"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt="The Ukrainian crisis and Biden's interests"  style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2021/02/Biden-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;">The Ukrainian crisis and Biden's interests</div></div></a><a class="relpost-block-single" href="https://countercurrents.org/2017/10/we-are-at-war-oh-really-some-questions/"><div class="relpost-custom-block-single" style="width: 150px; height: 225px;"><div class="relpost-block-single-image" alt=" “We Are At War!” Oh, Really? Some Questions"  style="background: transparent url(https://cdn.countercurrents.org/wp-content/uploads/2016/06/russia-usa-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px;"></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 12px;  color: #333333;"> “We Are At War!” Oh, Really? Some Questions</div></div></a></div><div style="clear: both"></div></div></div><div class="scriptlesssocialsharing"><h3 class="scriptlesssocialsharing__heading">Share:</h3><div class="scriptlesssocialsharing__buttons"><a class="button whatsapp" target="_blank" href="https://api.whatsapp.com/send?text=Modest%20results%20of%20the%20meeting%20in%20Geneva%20%E2%80%94%20https%3A%2F%2Fcountercurrents.org%2F2021%2F06%2Fmodest-results-of-the-meeting-in-geneva%2F" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>WhatsApp</span></a><a class="button facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fcountercurrents.org%2F2021%2F06%2Fmodest-results-of-the-meeting-in-geneva%2F" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Facebook</span></a><a class="button twitter" target="_blank" href="https://twitter.com/intent/tweet?text=Modest%20results%20of%20the%20meeting%20in%20Geneva&#038;url=https%3A%2F%2Fcountercurrents.org%2F2021%2F06%2Fmodest-results-of-the-meeting-in-geneva%2F&#038;via=countercurrents&#038;related=countercurrents" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Twitter</span></a><a class="button telegram" target="_blank" href="https://telegram.me/share/url?url=https%3A%2F%2Fcountercurrents.org%2F2021%2F06%2Fmodest-results-of-the-meeting-in-geneva%2F&#038;text=Modest%20results%20of%20the%20meeting%20in%20Geneva" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Telegram</span></a><a class="button reddit" target="_blank" href="https://www.reddit.com/submit?url=https%3A%2F%2Fcountercurrents.org%2F2021%2F06%2Fmodest-results-of-the-meeting-in-geneva%2F" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Reddit</span></a><a class="button email" href="mailto:?body=I%20read%20this%20post%20and%20wanted%20to%20share%20it%20with%20you.%20Here%27s%20the%20link%3A%20https%3A%2F%2Fcountercurrents.org%2F2021%2F06%2Fmodest-results-of-the-meeting-in-geneva%2F&#038;subject=A%20post%20worth%20sharing%3A%20Modest%20results%20of%20the%20meeting%20in%20Geneva" rel="noopener noreferrer nofollow"><span class="sss-name"><span class="screen-reader-text">Share on </span>Email</span></a></div></div><div class="clear"></div><div class="clear"></div></div><div class="clear"></div><div class="tag_list">Tags: <a href="https://countercurrents.org/tag/russia-us-relations/" rel="tag">Russia-US Relations</a></div></div><div class="share_box"><div class="share_btn"><a href="https://twitter.com/share" data-url="https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/" class="twitter-share-button" data-count="horizontal">Tweet</a><script type="text/javascript" src="https://platform.twitter.com/widgets.js"></script></div><div class="share_btn"><iframe src="https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fcountercurrents.org%2F2021%2F06%2Fmodest-results-of-the-meeting-in-geneva%2F&amp;layout=button_count&amp;show_faces=false&amp;width=1000&amp;action=like&amp;font=arial&amp;colorscheme=light&amp;height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:80px; height:21px;" allowtransparency="true"></iframe></div><div class="clear"></div></div><div class="post_author"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/8d2a2877c25211c2f19adbaf55f99f22?s=70&#038;r=g' srcset='https://secure.gravatar.com/avatar/8d2a2877c25211c2f19adbaf55f99f22?s=140&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2070%2070%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/8d2a2877c25211c2f19adbaf55f99f22?s=70&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/8d2a2877c25211c2f19adbaf55f99f22?s=140&#038;r=g 2x' class='lazyload avatar avatar-70 photo' height='70' width='70' /> <span>Author: <a href="https://countercurrents.org/author/slavisha-batko-milacic/" title="Posts by Slavisha Batko Milacic" rel="author">Slavisha Batko Milacic</a></span><p></p><div class="clear"></div> <span class="author_links"><ul><li>Visit Author:</li><li><a href="https://countercurrents.org/author/slavisha-batko-milacic/">All Posts</a></li></ul> </span></div><div class="clear"></div><div class="post-wrap"><div id="disqus_thread"></div> <script>var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"68466 https:\/\/countercurrents.org\/?p=68466","disqusShortname":"www-countercurrents-org","disqusTitle":"Modest results of the meeting in Geneva","disqusUrl":"https:\/\/countercurrents.org\/2021\/06\/modest-results-of-the-meeting-in-geneva\/","postId":68466};
    var disqus_url = embedVars.disqusUrl;
var disqus_identifier = embedVars.disqusIdentifier;
var disqus_container_id = 'disqus_thread';
var disqus_shortname = embedVars.disqusShortname;
var disqus_title = embedVars.disqusTitle;
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    var dsqConfig = embedVars.disqusConfig;
    this.page.integration = dsqConfig.integration;
    this.page.remote_auth_s3 = dsqConfig.remote_auth_s3;
    this.page.api_key = dsqConfig.api_key;
    this.sso = dsqConfig.sso;
    this.language = dsqConfig.language;

    if (disqus_config_custom)
        disqus_config_custom.call(this);
};

(function() {
    if (document.getElementById(disqus_container_id)) {
        var dsq = document.createElement('script');
        dsq.type = 'text/javascript';
        dsq.async = true;
        dsq.src = 'https://' + disqus_shortname + '.disqus.com/embed.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    }
})();</script> </div></div><div id="sidebar"><div id="custom_html-2" class="widget_text widget widget_custom_html"><h3 class="title"><div class="empty"></div></h3><div class="widget-content"><div class="textwidget custom-html-widget"><script async src="https://cse.google.com/cse.js?cx=009660411210412073649:WMX1323034037"></script> <div class="gcse-search"></div></div><div class="clear"></div></div></div><div id="media_image-3" class="widget widget_media_image"><h3 class="title"><div class="empty"></div></h3><div class="widget-content"><a href="https://countercurrents.org/subscription/"><img width="300" height="98" src="https://cdn.countercurrents.org/wp-content/uploads/2019/05/annual-Subscription-button-300x98.jpg" class="image wp-image-38371  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://cdn.countercurrents.org/wp-content/uploads/2019/05/annual-Subscription-button-300x98.jpg 300w, https://cdn.countercurrents.org/wp-content/uploads/2019/05/annual-Subscription-button-168x55.jpg 168w, https://cdn.countercurrents.org/wp-content/uploads/2019/05/annual-Subscription-button.jpg 327w" sizes="(max-width: 300px) 100vw, 300px" /></a><div class="clear"></div></div></div><div id="text-3" class="widget widget_text"><h3 class="title">Join Our Newsletter</h3><div class="widget-content"><div class="textwidget"><form method="post" action="https://scripts.dreamhost.com/add_list.cgi"> <input type="hidden" name="list" value="editor" /> <input type="hidden" name="domain" value="https://countercurrents.org" /> <input type="hidden" name="url" value="SubscribedURL" /> <input type="hidden" name="unsuburl" value="UnsubscribedURL" /> <input type="hidden" name="alreadyonurl" value="AlreadyOnURL" /> <input type="hidden" name="notonurl" value="NotOnURL" /> <input type="hidden" name="invalidurl" value="InvalidURL" /> <input type="hidden" name="emailconfirmurl" value="EmailConfirmURL" /> <input type="hidden" name="emailit" value="1" /><div> <label for="name">Name: </label> <input type="text" name="name"></div><div> <label for="email">Email: </label> <input type="text" name="email" placeholder="Enter a valid email" required></div> </br><div class="button"> <input type="submit" name="submit" value="Join Our Announcement List"></div></form></div><div class="clear"></div></div></div><div id="wpzoom-feature-posts-2" class="widget feature-posts"><h3 class="title">Latest</h3><div class="widget-content"><ul class="feature-posts-list"><li><a href="https://countercurrents.org/2021/06/obituary-com-ps-hochimin/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Hochimin-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Hochimin-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/obituary-com-ps-hochimin/">Obituary: Com. PS Hochimin</a> <br /><small><a href="https://countercurrents.org/author/chsn-murthy/" title="Posts by ChSN Murthy" rel="author">ChSN Murthy</a> | 19/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/epic-failure-of-humanity-global-displaced-population-hits-all-time-high/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Refugees-1-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Refugees-1-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/epic-failure-of-humanity-global-displaced-population-hits-all-time-high/">&#8216;Epic Failure of Humanity&#8217;: Global Displaced Population Hits All-Time High</a> <br /><small><a href="https://countercurrents.org/author/jake-johnson/" title="Posts by Jake Johnson" rel="author">Jake Johnson</a> | 19/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/geneva-summit-leading-from-the-front-while-dealing-with-media/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Putin-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Putin-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/geneva-summit-leading-from-the-front-while-dealing-with-media/">Geneva Summit: Leading from the front while dealing with media</a> <br /><small><a href="https://countercurrents.org/author/vidya-bhushan-rawat/" title="Posts by Vidya Bhushan Rawat" rel="author">Vidya Bhushan Rawat</a> | 19/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/why-the-approval-of-that-alzheimers-drug-is-so-disturbing/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Medicine-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Medicine-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/why-the-approval-of-that-alzheimers-drug-is-so-disturbing/">Why the Approval of That Alzheimer’s Drug Is So Disturbing</a> <br /><small><a href="https://countercurrents.org/author/tim-requarth/" title="Posts by Tim Requarth" rel="author">Tim Requarth</a> | 19/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Putin-Biden-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Putin-Biden-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/modest-results-of-the-meeting-in-geneva/">Modest results of the meeting in Geneva</a> <br /><small><a href="https://countercurrents.org/author/slavisha-batko-milacic/" title="Posts by Slavisha Batko Milacic" rel="author">Slavisha Batko Milacic</a> | 19/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/takeaways-from-biden-putin-summit/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Biden-Putin-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Biden-Putin-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/takeaways-from-biden-putin-summit/">Takeaways from Biden-Putin summit</a> <br /><small><a href="https://countercurrents.org/author/m-k-bhadrakumar/" title="Posts by M K Bhadrakumar" rel="author">M K Bhadrakumar</a> | 19/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/vaccine-woes-worry-india/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/3-1-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/3-1-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/vaccine-woes-worry-india/">Vaccine Woes Worry India</a> <br /><small><a href="https://countercurrents.org/author/ashish-singh/" title="Posts by Ashish Singh" rel="author">Ashish Singh</a> | 19/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/in-pandemic-times-no-one-should-be-made-homeless/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2020/07/Bhilai-house-demolition1-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2020/07/Bhilai-house-demolition1-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/in-pandemic-times-no-one-should-be-made-homeless/">In Pandemic Times No One Should Be Made Homeless</a> <br /><small><a href="https://countercurrents.org/author/bharat-dogra/" title="Posts by Bharat Dogra" rel="author">Bharat Dogra</a> | 19/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/supreme-court-verdict-turns-to-be-the-downfall-of-khori/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/press-conf-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/press-conf-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/supreme-court-verdict-turns-to-be-the-downfall-of-khori/"> Supreme Court verdict turns to be the downfall of Khori</a> <br /><small><a href="https://countercurrents.org/author/press-release/" title="Posts by Press Release" rel="author">Press Release</a> | 19/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/iit-gandhinagar-crushing-of-dissent-by-hobby-group-awaam/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/IIT-Gandhinagar-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/IIT-Gandhinagar-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/iit-gandhinagar-crushing-of-dissent-by-hobby-group-awaam/">IIT Gandhinagar: Crushing of Dissent by Hobby Group ‘Awaam’</a> <br /><small><a href="https://countercurrents.org/author/priya-jain/" title="Posts by Priya Jain" rel="author">Priya Jain</a> | 19/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/leader-close-to-indian-consulate-convicted-for-sex-assault/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Deepak-Sharma-sex-assault2-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Deepak-Sharma-sex-assault2-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/leader-close-to-indian-consulate-convicted-for-sex-assault/">Leader close to Indian consulate convicted for sex assault</a> <br /><small><a href="https://countercurrents.org/author/gurpreet-singh/" title="Posts by Gurpreet Singh" rel="author">Gurpreet Singh</a> | 19/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/threatening-writers-in-gujarat/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2018/11/Journalism-750x500-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2018/11/Journalism-750x500-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/threatening-writers-in-gujarat/">Threatening Writers In Gujarat</a> <br /><small><a href="https://countercurrents.org/author/press-release/" title="Posts by Press Release" rel="author">Press Release</a> | 19/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/protests-in-punjab-on-arrests-of-intellectuals-and-social-activists/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Bhima-Koregaon-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Bhima-Koregaon-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/protests-in-punjab-on-arrests-of-intellectuals-and-social-activists/">Protests in Punjab on arrests of intellectuals and social activists</a> <br /><small><a href="https://countercurrents.org/author/harsh-thakor/" title="Posts by Harsh Thakor" rel="author">Harsh Thakor</a> | 19/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/nizhal-in-the-shadow-of-the-surreal/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Nizhal-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Nizhal-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/nizhal-in-the-shadow-of-the-surreal/">Nizhal: In the Shadow of the Surreal</a> <br /><small><a href="https://countercurrents.org/author/shameer-k-sulaiman/" title="Posts by Shameer K Sulaiman" rel="author">Shameer K Sulaiman</a> | 19/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/usas-hypocritical-dealings-with-taliban/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/Taliban-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/Taliban-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/usas-hypocritical-dealings-with-taliban/">USA’s Hypocritical Dealings with Taliban</a> <br /><small><a href="https://countercurrents.org/author/yanis-iqbal/" title="Posts by Yanis Iqbal" rel="author">Yanis Iqbal</a> | 18/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/budget-2021-22-proposal-for-an-alternate-pro-people-budget/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/02/Union-Budget-2021-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/02/Union-Budget-2021-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/budget-2021-22-proposal-for-an-alternate-pro-people-budget/">Budget 2021–22: Proposal for an Alternate, Pro-People Budget</a> <br /><small><a href="https://countercurrents.org/author/neeraj-jain/" title="Posts by Neeraj Jain" rel="author">Neeraj Jain</a> | 18/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/mankinds-struggle-against-zoonotic-diseases-a-self-fulfilling-prophecy/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/wet-market-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/wet-market-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/mankinds-struggle-against-zoonotic-diseases-a-self-fulfilling-prophecy/">Mankind’s Struggle Against Zoonotic Diseases….a self fulfilling prophecy</a> <br /><small><a href="https://countercurrents.org/author/dr-harleen-shergill/" title="Posts by Dr Harleen Shergill" rel="author">Dr Harleen Shergill</a> | 18/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/impose-exit-tax-on-fleeing-rich-and-educated/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2019/07/flight-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2019/07/flight-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/impose-exit-tax-on-fleeing-rich-and-educated/">Impose Exit Tax on Fleeing Rich and Educated</a> <br /><small><a href="https://countercurrents.org/author/bharat-jhunjhunwala/" title="Posts by Bharat Jhunjhunwala" rel="author">Bharat Jhunjhunwala</a> | 18/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/distribute-vaccines-equitably-ensure-food-security-enhance-livelihood-opportunities/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2020/07/covid-vaccine-1-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2020/07/covid-vaccine-1-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/distribute-vaccines-equitably-ensure-food-security-enhance-livelihood-opportunities/">Distribute Vaccines Equitably, Ensure Food Security, Enhance Livelihood Opportunities</a> <br /><small><a href="https://countercurrents.org/author/right-to-food-campaign/" title="Posts by Right To Food Campaign" rel="author">Right To Food Campaign</a> | 18/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/prepare-for-both-dialogue-and-confrontation-with-u-s-says-n-koreas-leader-kim/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2017/03/Kim-Jong-Un-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2017/03/Kim-Jong-Un-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/prepare-for-both-dialogue-and-confrontation-with-u-s-says-n-koreas-leader-kim/">Prepare for both dialogue and confrontation with U.S., says N. Korea&#8217;s leader Kim</a> <br /><small><a href="https://countercurrents.org/author/countercurrents-org/" title="Posts by Countercurrents Collective" rel="author">Countercurrents Collective</a> | 18/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/nato-declares-china-as-global-security-challenge/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/NATO-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/NATO-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/nato-declares-china-as-global-security-challenge/">NATO declares China as global security challenge</a> <br /><small><a href="https://countercurrents.org/author/m-k-bhadrakumar/" title="Posts by M K Bhadrakumar" rel="author">M K Bhadrakumar</a> | 18/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/remembering-the-revolutionary-writer-ajmer-singh-aulakh/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Ajmer-Singh-Aulakh-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Ajmer-Singh-Aulakh-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/remembering-the-revolutionary-writer-ajmer-singh-aulakh/">Remembering The Revolutionary Writer Ajmer Singh Aulakh</a> <br /><small><a href="https://countercurrents.org/author/harsh-thakor/" title="Posts by Harsh Thakor" rel="author">Harsh Thakor</a> | 18/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/jharkhand-and-lalkhand/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Jharkhand-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Jharkhand-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/jharkhand-and-lalkhand/">Jharkhand and Lalkhand</a> <br /><small><a href="https://countercurrents.org/author/satyam-s/" title="Posts by Satyam S" rel="author">Satyam S</a> | 18/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/justin-trudeau-posturing-for-israel/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2019/03/Justin-Trudeau-1-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2019/03/Justin-Trudeau-1-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/justin-trudeau-posturing-for-israel/">Justin Trudeau posturing for Israel</a> <br /><small><a href="https://countercurrents.org/author/jim-miles/" title="Posts by Jim Miles" rel="author">Jim Miles</a> | 18/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/america-is-stabbing-itself-in-the-back/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2020/07/US-Troops-Afghanistan-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2020/07/US-Troops-Afghanistan-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/america-is-stabbing-itself-in-the-back/">America Is Stabbing Itself in the Back</a> <br /><small><a href="https://countercurrents.org/author/william-j-astore/" title="Posts by William J Astore" rel="author">William J Astore</a> | 18/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/problem-based-learning-solving-the-inherent-issues-in-the-education-system/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2020/12/Education-students-1-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2020/12/Education-students-1-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/problem-based-learning-solving-the-inherent-issues-in-the-education-system/">Problem-Based Learning – Solving the inherent issues in the education system</a> <br /><small><a href="https://countercurrents.org/author/bharatee-pandey/" title="Posts by Bharatee Pandey" rel="author">Bharatee Pandey</a> | 18/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/recent-increased-mortality-needs-urgent-attention/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/04/COVID-Death-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/04/COVID-Death-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/recent-increased-mortality-needs-urgent-attention/">Recent Increased Mortality Needs Urgent Attention</a> <br /><small><a href="https://countercurrents.org/author/bharat-dogra/" title="Posts by Bharat Dogra" rel="author">Bharat Dogra</a> | 18/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/our-nation-our-constitution-a-laypersons-understanding/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2019/12/defendindianconstitutionew-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2019/12/defendindianconstitutionew-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/our-nation-our-constitution-a-laypersons-understanding/">Our Nation, Our Constitution: A Layperson’s understanding</a> <br /><small><a href="https://countercurrents.org/author/s-g-vombatkere/" title="Posts by S G Vombatkere" rel="author">S G Vombatkere</a> | 18/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/voices-from-the-covid-battlefield-episode-one/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/COVID-Response-Watch-Logo-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/COVID-Response-Watch-Logo-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/voices-from-the-covid-battlefield-episode-one/">Voices from the Covid Battlefield  – Episode One</a> <br /><small><a href="https://countercurrents.org/author/dr-gajananan-phutke/" title="Posts by Dr Gajananan Phutke" rel="author">Dr Gajananan Phutke</a> | 18/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/heat-wave-scorches-the-u-s-west-50-million-people-under-warnings/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Temperature-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Temperature-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/heat-wave-scorches-the-u-s-west-50-million-people-under-warnings/">Heat wave scorches the U.S. West: 50 million people under warnings</a> <br /><small><a href="https://countercurrents.org/author/countercurrents-org/" title="Posts by Countercurrents Collective" rel="author">Countercurrents Collective</a> | 17/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/after-covid-a-pandemic-of-hunger-looms-large-in-mp/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/malnutrition1-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/malnutrition1-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/after-covid-a-pandemic-of-hunger-looms-large-in-mp/">After Covid, a pandemic of hunger looms large in MP</a> <br /><small><a href="https://countercurrents.org/author/shuchita-jha/" title="Posts by Shuchita Jha" rel="author">Shuchita Jha</a> | 17/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/pakistans-geopolitical-game-in-afghanistan/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/Taliban-1-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/Taliban-1-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/pakistans-geopolitical-game-in-afghanistan/">Pakistan’s Geopolitical Game in Afghanistan</a> <br /><small><a href="https://countercurrents.org/author/yanis-iqbal/" title="Posts by Yanis Iqbal" rel="author">Yanis Iqbal</a> | 17/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/the-carbis-bay-imperialism/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/G7-Summit-1-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/G7-Summit-1-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/the-carbis-bay-imperialism/">The Carbis Bay Imperialism</a> <br /><small><a href="https://countercurrents.org/author/bhabani-shankar-nayak/" title="Posts by Bhabani Shankar Nayak" rel="author">Bhabani Shankar Nayak</a> | 17/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/india-at-the-crossroads/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2019/06/congress-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2019/06/congress-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/india-at-the-crossroads/">India At The Crossroads</a> <br /><small><a href="https://countercurrents.org/author/hiren-gohain/" title="Posts by Hiren Gohain" rel="author">Hiren Gohain</a> | 17/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/age-consent-and-power-a-reading-of-my-dark-vanessa/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/My-Dark-Vanessa-75x50.jpeg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/My-Dark-Vanessa-75x50.jpeg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/age-consent-and-power-a-reading-of-my-dark-vanessa/">Age, Consent, and Power: A Reading of My Dark Vanessa</a> <br /><small><a href="https://countercurrents.org/author/shriyanshi-shukla/" title="Posts by Shriyanshi Shukla" rel="author">Shriyanshi Shukla</a> | 17/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/contradictions-in-the-anachronistic-us-russian-relationship/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Biden-Putin-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Biden-Putin-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/contradictions-in-the-anachronistic-us-russian-relationship/">Contradictions in the Anachronistic US-Russian Relationship</a> <br /><small><a href="https://countercurrents.org/author/jon-kofas/" title="Posts by Jon Kofas" rel="author">Jon Kofas</a> | 17/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/us-accent-is-on-bilateral-track-to-china/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Biden-Macron-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Biden-Macron-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/us-accent-is-on-bilateral-track-to-china/">US accent is on bilateral track to China</a> <br /><small><a href="https://countercurrents.org/author/m-k-bhadrakumar/" title="Posts by M K Bhadrakumar" rel="author">M K Bhadrakumar</a> | 17/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/essential-commodities-and-people/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Essential-Commodities-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Essential-Commodities-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/essential-commodities-and-people/">Essential Commodities And People</a> <br /><small><a href="https://countercurrents.org/author/s-g-vombatkere/" title="Posts by S G Vombatkere" rel="author">S G Vombatkere</a> | 17/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/milk-producers-face-increasing-problems-need-protection/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Dairy-Farmers-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/06/Dairy-Farmers-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/milk-producers-face-increasing-problems-need-protection/">Milk Producers Face Increasing Problems, Need Protection</a> <br /><small><a href="https://countercurrents.org/author/bharat-dogra/" title="Posts by Bharat Dogra" rel="author">Bharat Dogra</a> | 17/06/2021 </small> <br/><div class="clear"></div></li><li><a href="https://countercurrents.org/2021/06/on-trumpism-and-netanyahu-ism-how-benjamin-netanyahu-won-america-and-lost-israel/"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2019/09/benjamin-netanyahu-75x50.jpg" height="50" width="75"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2075%2050%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2019/09/benjamin-netanyahu-75x50.jpg" height="50" width="75"></a><a href="https://countercurrents.org/2021/06/on-trumpism-and-netanyahu-ism-how-benjamin-netanyahu-won-america-and-lost-israel/">On Trumpism and Netanyahu-ism: How Benjamin Netanyahu Won America and Lost Israel </a> <br /><small><a href="https://countercurrents.org/author/dr-ramzy-baroud/" title="Posts by Dr Ramzy Baroud" rel="author">Dr Ramzy Baroud</a> | 17/06/2021 </small> <br/><div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div></div><div class="featured-category"><h3 class="green"><a href="https://countercurrents.org/editors-picks/">Editor’s Picks</a></h3><div class="left-col"> <a href="https://countercurrents.org/2021/06/when-cow-dung-meets-coronavirus/" title="When Cow Dung Meets Coronavirus"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/COVID-Response-Watch-Logo-300x200.jpg" alt="When Cow Dung Meets Coronavirus" class="Thumbnail thumbnail featured-cat" width="300" height="200" /></noscript><img src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%20200%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/COVID-Response-Watch-Logo-300x200.jpg" alt="When Cow Dung Meets Coronavirus" class="lazyload Thumbnail thumbnail featured-cat" width="300" height="200" /></a><div class="clear"></div><div class="left-col-content"><h2><a href="https://countercurrents.org/2021/06/when-cow-dung-meets-coronavirus/" title="When Cow Dung Meets Coronavirus">When Cow Dung Meets Coronavirus</a></h2><div class="featured-meta"> <span>01/06/2021</span> <span class="separator">&mdash;</span> <span>Satya Sagar</span></div><p>Share:Share on WhatsAppShare on FacebookShare on TwitterShare on TelegramShare on RedditShare on Email  “Cow dung, cow urine didn’t work. Groundless argument. Tomorrow I will eat fish”. In mid-May this year, this simple Facebook post about the futility of bovine waste as a cure for Covid-19, was enough to get Kishorechandra Wangkhem, a journalist from Imphal, Manipur arrested for ‘sedition’ .<a class="more-link" href="https://countercurrents.org/2021/06/when-cow-dung-meets-coronavirus/">[Read More&#8230;]</a></p></div></div><div class="right-col"><ul><li> <a href="https://countercurrents.org/2021/05/caste-class-and-indias-covid-catastrophe/" title="Caste, Class and India’s Covid Catastrophe"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/COVID-Response-Watch-Logo-100x75.jpg" alt="Caste, Class and India’s Covid Catastrophe" class="Thumbnail thumbnail featured-cat-small" width="100" height="75" /></noscript><img src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2075%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/COVID-Response-Watch-Logo-100x75.jpg" alt="Caste, Class and India’s Covid Catastrophe" class="lazyload Thumbnail thumbnail featured-cat-small" width="100" height="75" /></a><div class="right-col-content"><h4><a href="https://countercurrents.org/2021/05/caste-class-and-indias-covid-catastrophe/" title="Caste, Class and India’s Covid Catastrophe">Caste, Class and India’s Covid Catastrophe</a></h4><div class="featured-meta"> <span>21/05/2021</span> <span class="separator">&mdash;</span> <span>Satya Sagar</span></div></div><div style="clear:both;"></div></li><li> <a href="https://countercurrents.org/2021/05/when-death-floats-down-the-ganga/" title="When death floats down the Ganga"><noscript><img src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/COVID-Response-Watch-Logo-100x75.jpg" alt="When death floats down the Ganga" class="Thumbnail thumbnail featured-cat-small" width="100" height="75" /></noscript><img src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20100%2075%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2021/05/COVID-Response-Watch-Logo-100x75.jpg" alt="When death floats down the Ganga" class="lazyload Thumbnail thumbnail featured-cat-small" width="100" height="75" /></a><div class="right-col-content"><h4><a href="https://countercurrents.org/2021/05/when-death-floats-down-the-ganga/" title="When death floats down the Ganga">When death floats down the Ganga</a></h4><div class="featured-meta"> <span>17/05/2021</span> <span class="separator">&mdash;</span> <span>B Sivaraman</span></div></div><div style="clear:both;"></div></li></ul></div><div class="clear"></div></div><div id="archives-2" class="widget widget_archive"><h3 class="title">Archives</h3><div class="widget-content"><ul><li><a href='https://countercurrents.org/2021/06/'>June 2021</a></li><li><a href='https://countercurrents.org/2021/05/'>May 2021</a></li><li><a href='https://countercurrents.org/2021/04/'>April 2021</a></li><li><a href='https://countercurrents.org/2021/03/'>March 2021</a></li><li><a href='https://countercurrents.org/2021/02/'>February 2021</a></li><li><a href='https://countercurrents.org/2021/01/'>January 2021</a></li><li><a href='https://countercurrents.org/2020/12/'>December 2020</a></li><li><a href='https://countercurrents.org/2020/11/'>November 2020</a></li><li><a href='https://countercurrents.org/2020/10/'>October 2020</a></li><li><a href='https://countercurrents.org/2020/09/'>September 2020</a></li><li><a href='https://countercurrents.org/2020/08/'>August 2020</a></li><li><a href='https://countercurrents.org/2020/07/'>July 2020</a></li><li><a href='https://countercurrents.org/2020/06/'>June 2020</a></li><li><a href='https://countercurrents.org/2020/05/'>May 2020</a></li><li><a href='https://countercurrents.org/2020/04/'>April 2020</a></li><li><a href='https://countercurrents.org/2020/03/'>March 2020</a></li><li><a href='https://countercurrents.org/2020/02/'>February 2020</a></li><li><a href='https://countercurrents.org/2020/01/'>January 2020</a></li><li><a href='https://countercurrents.org/2019/12/'>December 2019</a></li><li><a href='https://countercurrents.org/2019/11/'>November 2019</a></li><li><a href='https://countercurrents.org/2019/10/'>October 2019</a></li><li><a href='https://countercurrents.org/2019/09/'>September 2019</a></li><li><a href='https://countercurrents.org/2019/08/'>August 2019</a></li><li><a href='https://countercurrents.org/2019/07/'>July 2019</a></li><li><a href='https://countercurrents.org/2019/06/'>June 2019</a></li><li><a href='https://countercurrents.org/2019/05/'>May 2019</a></li><li><a href='https://countercurrents.org/2019/04/'>April 2019</a></li><li><a href='https://countercurrents.org/2019/03/'>March 2019</a></li><li><a href='https://countercurrents.org/2019/02/'>February 2019</a></li><li><a href='https://countercurrents.org/2019/01/'>January 2019</a></li><li><a href='https://countercurrents.org/2018/12/'>December 2018</a></li><li><a href='https://countercurrents.org/2018/11/'>November 2018</a></li><li><a href='https://countercurrents.org/2018/10/'>October 2018</a></li><li><a href='https://countercurrents.org/2018/09/'>September 2018</a></li><li><a href='https://countercurrents.org/2018/08/'>August 2018</a></li><li><a href='https://countercurrents.org/2018/07/'>July 2018</a></li><li><a href='https://countercurrents.org/2018/06/'>June 2018</a></li><li><a href='https://countercurrents.org/2018/05/'>May 2018</a></li><li><a href='https://countercurrents.org/2018/04/'>April 2018</a></li><li><a href='https://countercurrents.org/2018/03/'>March 2018</a></li><li><a href='https://countercurrents.org/2018/02/'>February 2018</a></li><li><a href='https://countercurrents.org/2018/01/'>January 2018</a></li><li><a href='https://countercurrents.org/2017/12/'>December 2017</a></li><li><a href='https://countercurrents.org/2017/11/'>November 2017</a></li><li><a href='https://countercurrents.org/2017/10/'>October 2017</a></li><li><a href='https://countercurrents.org/2017/09/'>September 2017</a></li><li><a href='https://countercurrents.org/2017/08/'>August 2017</a></li><li><a href='https://countercurrents.org/2017/07/'>July 2017</a></li><li><a href='https://countercurrents.org/2017/06/'>June 2017</a></li><li><a href='https://countercurrents.org/2017/05/'>May 2017</a></li><li><a href='https://countercurrents.org/2017/04/'>April 2017</a></li><li><a href='https://countercurrents.org/2017/03/'>March 2017</a></li><li><a href='https://countercurrents.org/2017/02/'>February 2017</a></li><li><a href='https://countercurrents.org/2017/01/'>January 2017</a></li><li><a href='https://countercurrents.org/2016/12/'>December 2016</a></li><li><a href='https://countercurrents.org/2016/11/'>November 2016</a></li><li><a href='https://countercurrents.org/2016/10/'>October 2016</a></li><li><a href='https://countercurrents.org/2016/09/'>September 2016</a></li><li><a href='https://countercurrents.org/2016/08/'>August 2016</a></li><li><a href='https://countercurrents.org/2016/07/'>July 2016</a></li><li><a href='https://countercurrents.org/2016/06/'>June 2016</a></li><li><a href='https://countercurrents.org/2015/11/'>November 2015</a></li></ul><div class="clear"></div></div></div><div id="media_image-2" class="widget widget_media_image"><h3 class="title"><div class="empty"></div></h3><div class="widget-content"><a href="https://countercurrents.org/home.htm"><noscript><img width="300" height="98" src="https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn-300x98.jpg" class="image wp-image-2060  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn-300x98.jpg 300w, https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn-168x55.jpg 168w, https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn.jpg 327w" sizes="(max-width: 300px) 100vw, 300px" /></noscript><img width="300" height="98" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%2098%22%3E%3C/svg%3E' data-src="https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn-300x98.jpg" class="lazyload image wp-image-2060  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" data-srcset="https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn-300x98.jpg 300w, https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn-168x55.jpg 168w, https://cdn.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn.jpg 327w" data-sizes="(max-width: 300px) 100vw, 300px" /></a><div class="clear"></div></div></div><div id="tag_cloud-2" class="widget widget_tag_cloud"><h3 class="title">Tags</h3><div class="widget-content"><div class="tagcloud"><a href="https://countercurrents.org/tag/afghanistan/" class="tag-cloud-link tag-link-702 tag-link-position-1" style="font-size: 11.315789473684pt;" aria-label="Afghanistan (97 items)">Afghanistan</a> <a href="https://countercurrents.org/tag/american-imperialism/" class="tag-cloud-link tag-link-156 tag-link-position-2" style="font-size: 15.982456140351pt;" aria-label="American Imperialism (232 items)">American Imperialism</a> <a href="https://countercurrents.org/tag/annihilate-caste/" class="tag-cloud-link tag-link-151 tag-link-position-3" style="font-size: 8.1228070175439pt;" aria-label="Annihilate Caste (53 items)">Annihilate Caste</a> <a href="https://countercurrents.org/tag/bhima-koregaon/" class="tag-cloud-link tag-link-1688 tag-link-position-4" style="font-size: 11.438596491228pt;" aria-label="Bhima Koregaon (100 items)">Bhima Koregaon</a> <a href="https://countercurrents.org/tag/black-lives-matter/" class="tag-cloud-link tag-link-371 tag-link-position-5" style="font-size: 10.456140350877pt;" aria-label="Black Lives Matter (82 items)">Black Lives Matter</a> <a href="https://countercurrents.org/tag/book-review/" class="tag-cloud-link tag-link-351 tag-link-position-6" style="font-size: 12.912280701754pt;" aria-label="Book Review (132 items)">Book Review</a> <a href="https://countercurrents.org/tag/brexit/" class="tag-cloud-link tag-link-189 tag-link-position-7" style="font-size: 8.7368421052632pt;" aria-label="Brexit (59 items)">Brexit</a> <a href="https://countercurrents.org/tag/capitalism/" class="tag-cloud-link tag-link-651 tag-link-position-8" style="font-size: 8.4912280701754pt;" aria-label="Capitalism (57 items)">Capitalism</a> <a href="https://countercurrents.org/tag/cartoons/" class="tag-cloud-link tag-link-1390 tag-link-position-9" style="font-size: 8.859649122807pt;" aria-label="Cartoons (60 items)">Cartoons</a> <a href="https://countercurrents.org/tag/citizenship-amendment-act/" class="tag-cloud-link tag-link-1963 tag-link-position-10" style="font-size: 13.526315789474pt;" aria-label="Citizenship Amendment Act (146 items)">Citizenship Amendment Act</a> <a href="https://countercurrents.org/tag/climate-change/" class="tag-cloud-link tag-link-174 tag-link-position-11" style="font-size: 15.859649122807pt;" aria-label="Climate Change (230 items)">Climate Change</a> <a href="https://countercurrents.org/tag/coronavirus/" class="tag-cloud-link tag-link-2035 tag-link-position-12" style="font-size: 22pt;" aria-label="Coronavirus (721 items)">Coronavirus</a> <a href="https://countercurrents.org/tag/counter-solutions/" class="tag-cloud-link tag-link-185 tag-link-position-13" style="font-size: 11.438596491228pt;" aria-label="Counter Solutions (98 items)">Counter Solutions</a> <a href="https://countercurrents.org/tag/covid19/" class="tag-cloud-link tag-link-2152 tag-link-position-14" style="font-size: 18.684210526316pt;" aria-label="COVID19 (392 items)">COVID19</a> <a href="https://countercurrents.org/tag/dakota-access-pipeline/" class="tag-cloud-link tag-link-656 tag-link-position-15" style="font-size: 10.333333333333pt;" aria-label="Dakota Access Pipeline (80 items)">Dakota Access Pipeline</a> <a href="https://countercurrents.org/tag/demonetisation/" class="tag-cloud-link tag-link-925 tag-link-position-16" style="font-size: 12.666666666667pt;" aria-label="Demonetisation (125 items)">Demonetisation</a> <a href="https://countercurrents.org/tag/donald-trump/" class="tag-cloud-link tag-link-353 tag-link-position-17" style="font-size: 15.614035087719pt;" aria-label="Donald Trump (216 items)">Donald Trump</a> <a href="https://countercurrents.org/tag/education/" class="tag-cloud-link tag-link-331 tag-link-position-18" style="font-size: 14.263157894737pt;" aria-label="Education (169 items)">Education</a> <a href="https://countercurrents.org/tag/environment/" class="tag-cloud-link tag-link-175 tag-link-position-19" style="font-size: 11.684210526316pt;" aria-label="Environment (104 items)">Environment</a> <a href="https://countercurrents.org/tag/farmers-march/" class="tag-cloud-link tag-link-1771 tag-link-position-20" style="font-size: 15.859649122807pt;" aria-label="Farmers Agitation (227 items)">Farmers Agitation</a> <a href="https://countercurrents.org/tag/farmers-bills/" class="tag-cloud-link tag-link-49990 tag-link-position-21" style="font-size: 15.982456140351pt;" aria-label="Farm Reform Laws (234 items)">Farm Reform Laws</a> <a href="https://countercurrents.org/tag/film-review/" class="tag-cloud-link tag-link-240 tag-link-position-22" style="font-size: 11.438596491228pt;" aria-label="Film Review (100 items)">Film Review</a> <a href="https://countercurrents.org/tag/gaza/" class="tag-cloud-link tag-link-305 tag-link-position-23" style="font-size: 8.6140350877193pt;" aria-label="Gaza (58 items)">Gaza</a> <a href="https://countercurrents.org/tag/global-warming/" class="tag-cloud-link tag-link-193 tag-link-position-24" style="font-size: 14.508771929825pt;" aria-label="Global Warming (178 items)">Global Warming</a> <a href="https://countercurrents.org/tag/health/" class="tag-cloud-link tag-link-301 tag-link-position-25" style="font-size: 13.035087719298pt;" aria-label="Health (135 items)">Health</a> <a href="https://countercurrents.org/tag/hillary-clinton/" class="tag-cloud-link tag-link-308 tag-link-position-26" style="font-size: 8.4912280701754pt;" aria-label="Hillary Clinton (56 items)">Hillary Clinton</a> <a href="https://countercurrents.org/tag/human-rights/" class="tag-cloud-link tag-link-152 tag-link-position-27" style="font-size: 11.684210526316pt;" aria-label="Human Rights (104 items)">Human Rights</a> <a href="https://countercurrents.org/tag/india-china-border-conflict/" class="tag-cloud-link tag-link-1462 tag-link-position-28" style="font-size: 9.3508771929825pt;" aria-label="India China Border Conflict (66 items)">India China Border Conflict</a> <a href="https://countercurrents.org/tag/iran/" class="tag-cloud-link tag-link-233 tag-link-position-29" style="font-size: 9.2280701754386pt;" aria-label="Iran (65 items)">Iran</a> <a href="https://countercurrents.org/tag/israel/" class="tag-cloud-link tag-link-218 tag-link-position-30" style="font-size: 13.40350877193pt;" aria-label="Israel (144 items)">Israel</a> <a href="https://countercurrents.org/tag/julian-assange/" class="tag-cloud-link tag-link-693 tag-link-position-31" style="font-size: 13.40350877193pt;" aria-label="Julian Assange (145 items)">Julian Assange</a> <a href="https://countercurrents.org/tag/kashmir/" class="tag-cloud-link tag-link-164 tag-link-position-32" style="font-size: 17.333333333333pt;" aria-label="Kashmir (304 items)">Kashmir</a> <a href="https://countercurrents.org/tag/life/" class="tag-cloud-link tag-link-45931 tag-link-position-33" style="font-size: 14.754385964912pt;" aria-label="Life (187 items)">Life</a> <a href="https://countercurrents.org/tag/nuclear-war/" class="tag-cloud-link tag-link-198 tag-link-position-34" style="font-size: 8pt;" aria-label="Nuclear War (51 items)">Nuclear War</a> <a href="https://countercurrents.org/tag/palestine/" class="tag-cloud-link tag-link-217 tag-link-position-35" style="font-size: 16.842105263158pt;" aria-label="Palestine (272 items)">Palestine</a> <a href="https://countercurrents.org/tag/patriarchy/" class="tag-cloud-link tag-link-161 tag-link-position-36" style="font-size: 8pt;" aria-label="Patriarchy (52 items)">Patriarchy</a> <a href="https://countercurrents.org/tag/poetry/" class="tag-cloud-link tag-link-228 tag-link-position-37" style="font-size: 17.824561403509pt;" aria-label="Poetry (328 items)">Poetry</a> <a href="https://countercurrents.org/tag/rohingya-muslims/" class="tag-cloud-link tag-link-872 tag-link-position-38" style="font-size: 8.4912280701754pt;" aria-label="Rohingya Muslims (57 items)">Rohingya Muslims</a> <a href="https://countercurrents.org/tag/standing-rock-sioux-protest/" class="tag-cloud-link tag-link-655 tag-link-position-39" style="font-size: 10.210526315789pt;" aria-label="Standing Rock Sioux Protest (79 items)">Standing Rock Sioux Protest</a> <a href="https://countercurrents.org/tag/syria/" class="tag-cloud-link tag-link-244 tag-link-position-40" style="font-size: 12.789473684211pt;" aria-label="Syria (127 items)">Syria</a> <a href="https://countercurrents.org/tag/the-commons/" class="tag-cloud-link tag-link-344 tag-link-position-41" style="font-size: 11.315789473684pt;" aria-label="The Commons (96 items)">The Commons</a> <a href="https://countercurrents.org/tag/us-election-2020/" class="tag-cloud-link tag-link-2043 tag-link-position-42" style="font-size: 10.824561403509pt;" aria-label="US Election 2020 (89 items)">US Election 2020</a> <a href="https://countercurrents.org/tag/us-elections-2016/" class="tag-cloud-link tag-link-283 tag-link-position-43" style="font-size: 10.824561403509pt;" aria-label="US Elections 2016 (89 items)">US Elections 2016</a> <a href="https://countercurrents.org/tag/venezuela/" class="tag-cloud-link tag-link-366 tag-link-position-44" style="font-size: 15.368421052632pt;" aria-label="Venezuela (206 items)">Venezuela</a> <a href="https://countercurrents.org/tag/yemen/" class="tag-cloud-link tag-link-489 tag-link-position-45" style="font-size: 10.087719298246pt;" aria-label="Yemen (76 items)">Yemen</a></div><div class="clear"></div></div></div></div><div class="clear"></div><div id="footer"><div class="column"></div><div class="column"></div><div class="column"></div><div class="column last"></div><div class="clear"></div></div><div class="clear"></div></div></div><div id="copyright"><div class="inner-wrap"> Copyright &copy; 2021 &mdash; <a href="https://countercurrents.org/" class="on">Countercurrents</a>. All Rights Reserved. <span>optimized by <a href="https://anivar.net/" target="_blank" title="Anivar Aravind">Anivar</a></span></div></div>  <script>var hide_fttb = ''</script> <script type="text/javascript">if ((navigator.doNotTrack==="yes") || (navigator.msDoNotTrack=="1") || (navigator.doNotTrack=="1") || (document.cookie.indexOf("dont_track_me=1")!==-1) || (document.cookie.indexOf("civicAllowCookies=no")!==-1)) { 
aop_around(document.body, 'appendChild'); aop_around(document.body, 'insertBefore');  
 }</script>  <script>(function(a, b, c) {
        var d = a.history,
            e = document,
            f = navigator || {},
            g = localStorage,
            h = encodeURIComponent,
            i = d.pushState,
            k = function() {
                return Math.random().toString(36)
            },
            l = function() {
                return g.cid || (g.cid = k()), g.cid
            },
            m = function(r) {
                var s = [];
                for (var t in r) r.hasOwnProperty(t) && void 0 !== r[t] && s.push(h(t) + "=" + h(r[t]));
                return s.join("&")
            },
            n = function(r, s, t, u, v, w, x) {
                var z = "https://countercurrents.org/wp-json/caos/v1/proxy/collect",
                    A = m({
                        v: "1",
                        ds: "web",
                        aip: c.anonymizeIp ? 1 : void 0,
                        tid: b,
                        cid: l(),
                        t: r || "pageview",
                        sd: c.colorDepth && screen.colorDepth ? screen.colorDepth + "-bits" : void 0,
                        dr: e.referrer || void 0,
                        dt: e.title,
                        dl: e.location.origin + e.location.pathname + e.location.search,
                        ul: c.language ? (f.language || "").toLowerCase() : void 0,
                        de: c.characterSet ? e.characterSet : void 0,
                        sr: c.screenSize ? (a.screen || {}).width + "x" + (a.screen || {}).height : void 0,
                        vp: c.screenSize && a.visualViewport ? (a.visualViewport || {}).width + "x" + (a.visualViewport || {}).height : void 0,
                        ec: s || void 0,
                        ea: t || void 0,
                        el: u || void 0,
                        ev: v || void 0,
                        exd: w || void 0,
                        exf: "undefined" != typeof x && !1 == !!x ? 0 : void 0
                    });
                if (f.sendBeacon) f.sendBeacon(z, A);
                else {
                    var y = new XMLHttpRequest;
                    y.open("POST", z, !0), y.send(A)
                }
            };
        d.pushState = function(r) {
            return "function" == typeof d.onpushstate && d.onpushstate({
                state: r
            }), setTimeout(n, c.delay || 10), i.apply(d, arguments)
        }, n(), a.ma = {
            trackEvent: function o(r, s, t, u) {
                return n("event", r, s, t, u)
            },
            trackException: function q(r, s) {
                return n("exception", null, null, null, null, r, s)
            }
        }
    })(window, "UA-166669197-1", {
        anonymizeIp: false,
        siteSpeedSampleRate: 1,
        colorDepth: true,
        characterSet: true,
        screenSize: true,
        language: true
    });</script><noscript><style>.lazyload{display:none;}</style></noscript><script data-noptimize="1">window.lazySizesConfig=window.lazySizesConfig||{};window.lazySizesConfig.loadMode=1;</script><script async data-noptimize="1" src='https://cdn.countercurrents.org/wp-content/plugins/autoptimize/classes/external/js/lazysizes.min.js?ao_version=2.8.4'></script> <script type='text/javascript' id='fttb-active-js-extra'>var fttb = {"topdistance":"300","topspeed":"300","animation":"fade","animationinspeed":"200","animationoutspeed":"200","scrolltext":"","imgurl":"https:\/\/countercurrents.org\/wp-content\/plugins\/float-to-top-button\/images\/","arrow_img":"arrow014.png","arrow_img_url":"","position":"lowerright","spacing_horizontal":"40px","spacing_vertical":"40px","opacity_out":"75","opacity_over":"99","zindex":"2147483647"};</script> <script type='text/javascript' id='disqus_count-js-extra'>var countVars = {"disqusShortname":"www-countercurrents-org"};</script> <script type='text/javascript' id='ppress-frontend-script-js-extra'>var pp_ajax_form = {"ajaxurl":"https:\/\/countercurrents.org\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"301e9aa3ab","disable_ajax_form":"false"};</script> <script type="text/javascript" id="flying-scripts">const loadScriptsTimer=setTimeout(loadScripts,6*1000);const userInteractionEvents=["mouseover","keydown","touchstart","touchmove","wheel"];userInteractionEvents.forEach(function(event){window.addEventListener(event,triggerScriptLoader,{passive:!0})});function triggerScriptLoader(){loadScripts();clearTimeout(loadScriptsTimer);userInteractionEvents.forEach(function(event){window.removeEventListener(event,triggerScriptLoader,{passive:!0})})}
function loadScripts(){document.querySelectorAll("script[data-type='lazy']").forEach(function(elem){elem.setAttribute("src",elem.getAttribute("data-src"))})}</script> <script defer src="https://cdn.countercurrents.org/wp-content/cache/autoptimize/js/autoptimize_adf8a9891dd6eb9a7055358c185b84c2.js"></script></body></html>